Skip to content

Commit

Permalink
dev-python/boto3: Bump to 1.16.18
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 14, 2020
1 parent aa703ab commit 16076fc
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/boto3/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,4 +9,5 @@ DIST boto3-1.16.14.tar.gz 338870 BLAKE2B 71ee68c7d4dce99a6534dffa1f65717f6d68460
DIST boto3-1.16.15.tar.gz 338877 BLAKE2B 817fab1f721419cf061b833f1e3e531a0480747fc7879ed048a62b481048f762bd78271832a85e782b91ffc6eebd7bb21550715c0c2cf7bfcea1f3d7ed8d3f8e SHA512 7b5bcbacfa733a81a2dbbaff89e244a37dee280e10263871bfda1e844760584ac350b4fafa721bd2ef39696e80bf317011a1d39f9baa29197b4a224ef74bfa53
DIST boto3-1.16.16.tar.gz 338959 BLAKE2B e34c14b89ddd402e4ca7037e1fdbb5121ff9eb2c7fefb67eabadb378cc4f8e5f5ddc3c933d366d086155b4b16319ed9e7d85af21bca1da0f17be3c2171dc9c1a SHA512 b0d0cf8877ac66e28f925c3eda6e02c845c8753c96ebb8684d7eb3a3e82ac6323ae8775715bcf7c70889921e53b0224561460cbc0c95ae56a17d606c75245971
DIST boto3-1.16.17.tar.gz 339112 BLAKE2B e5db626fd2a3b1b8a12fbf5f4113c482d4ae0e04eb0b7090ebe75e417c4a3a9a762129a8cfc342fb8550d67b36750de6f5fceccc8a653f27a2201c9be85de466 SHA512 5842cb056ef4b418628778cf0e7c362c6d1175565060008c2ff5fa3b726fccaec96bb1133c8e82788d8f1a2e527fb154a234eb606804f97463e04f0f64c57a1c
DIST boto3-1.16.18.tar.gz 339220 BLAKE2B 795ed9b7f201c36bb12ff8d10484abd92ff36d821817a8fa0be2c8f8a16d352367e9c03a465ce0d27a346121a6974710c42450bb97fe5d844fab57d1fb44b817 SHA512 fdc2e994a3c73d521e88706886f2d5170281e4d83db2804da1aaf3afb1c14a7bf443ec17d15708e6227ca6b069909f89a9ed790c68aec15e35f9b4a9951b2d63
DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
56 changes: 56 additions & 0 deletions dev-python/boto3/boto3-1.16.18.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1

DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="https://github.com/boto/boto3"
LICENSE="Apache-2.0"
SLOT="0"

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
inherit git-r3
BOTOCORE_PV=${PV}
else
SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"

# botocore is x.(y+3).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
fi

RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"

distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
distutils_enable_tests nose

python_prepare_all() {
# don't lock versions to narrow ranges
sed -e '/botocore/ d' \
-e '/jmespath/ d' \
-e '/s3transfer/ d' \
-i setup.py || die

# prevent an infinite loop
rm tests/functional/docs/test_smoke.py || die

distutils-r1_python_prepare_all
}

python_test() {
nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
}

0 comments on commit 16076fc

Please sign in to comment.