forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
sys-apps/selinux-python: bump to 2.7_rc1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
98 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST selinux-python-2.7-rc1.tar.gz 2067791 SHA256 29aa4b914a11f54c05670d09a92327cc1fe5203af41ec5ece837a7fc3f5563ac SHA512 8d0f774dd04b52d404cfdd0ed3bab7d83269a7881ff8a4f1170292193cdccb2cdbdc9456dd473fdaaa2b63584bfe0385e76a0e2315f6a9298dc5cf1c7b928c0f WHIRLPOOL 37ba7397a5523d1ed283d3d4d71e8643040d3b5ab37c90e64aed90d1190bca53480c3c034512ffda62b8494386bc1759013190fa4699befa4aee86d561e7a67c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,97 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
PYTHON_COMPAT=( python{2_7,3_4,3_5} ) | ||
PYTHON_REQ_USE="xml" | ||
|
||
inherit python-r1 toolchain-funcs | ||
|
||
MY_P="${P//_/-}" | ||
|
||
MY_RELEASEDATE="20170609" | ||
SEPOL_VER="${PV}" | ||
SELNX_VER="${PV}" | ||
SEMNG_VER="${PV}" | ||
|
||
IUSE="audit pam dbus" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
DESCRIPTION="SELinux core utilities" | ||
HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki" | ||
|
||
if [[ ${PV} == 9999 ]] ; then | ||
inherit git-r3 | ||
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git" | ||
S="${WORKDIR}/${MY_P}/${PN#selinux-}" | ||
else | ||
SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/${MY_RELEASEDATE}/${MY_P}.tar.gz" | ||
KEYWORDS="~amd64 ~arm64 ~mips ~x86" | ||
S="${WORKDIR}/${MY_P}" | ||
fi | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
|
||
DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python] | ||
>=sys-libs/libsemanage-${SEMNG_VER}:=[python] | ||
>=sys-libs/libsepol-${SEPOL_VER}:= | ||
>=app-admin/setools-4.0 | ||
dev-python/ipy[${PYTHON_USEDEP}] | ||
!dev-python/sepolgen | ||
${PYTHON_DEPS}" | ||
|
||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
sed -i 's/-Werror//g' "${S}"/*/Makefile || die "Failed to remove Werror" | ||
|
||
python_copy_sources | ||
} | ||
|
||
src_compile() { | ||
building() { | ||
emake -C "${BUILD_DIR}" \ | ||
CC="$(tc-getCC)" \ | ||
PYLIBVER="${EPYTHON}" \ | ||
LIBDIR="\$(PREFIX)/$(get_libdir)" | ||
} | ||
python_foreach_impl building | ||
} | ||
|
||
src_install() { | ||
installation() { | ||
emake -C "${BUILD_DIR}" \ | ||
DESTDIR="${D}" \ | ||
LIBDIR="\$(PREFIX)/$(get_libdir)" \ | ||
LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \ | ||
install | ||
python_optimize | ||
} | ||
python_foreach_impl installation | ||
|
||
# Set version-specific scripts | ||
for pyscript in audit2allow sepolgen-ifgen sepolicy chcat; do | ||
python_replicate_script "${ED}/usr/bin/${pyscript}" | ||
done | ||
for pyscript in semanage; do | ||
python_replicate_script "${ED}/usr/sbin/${pyscript}" | ||
done | ||
|
||
# Create sepolgen.conf with different devel location definition | ||
if [[ -f /etc/selinux/config ]]; | ||
then | ||
local selinuxtype=$(awk -F'=' '/^SELINUXTYPE/ {print $2}' /etc/selinux/config); | ||
mkdir -p "${D}"/etc/selinux || die "Failed to create selinux directory"; | ||
echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf; | ||
else | ||
local selinuxtype="${POLICY_TYPES%% *}"; | ||
if [[ -n "${selinuxtype}" ]]; | ||
then | ||
echo "SELINUX_DEVEL_PATH=/usr/share/selinux/${selinuxtype}/include:/usr/share/selinux/${selinuxtype}" > "${D}"/etc/selinux/sepolgen.conf; | ||
else | ||
echo "SELINUX_DEVEL_PATH=/usr/share/selinux/strict/include:/usr/share/selinux/strict" > "${D}"/etc/selinux/sepolgen.conf; | ||
fi | ||
fi | ||
} |