Skip to content

Commit

Permalink
gnustep-base/libobjc2: version bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.22
  • Loading branch information
voyageur committed Oct 1, 2015
1 parent c285de2 commit 161b74a
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnustep-base/libobjc2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libobjc2-1.8.1.tar.gz 173635 SHA256 472bd684070c4dc6e78293836f426c1c6981c3818b546f74ec400bb8f13df925 SHA512 518f36e96a82a076fc67fe384226bd97310cd10a53c7b0951db9f3658aa534582b245d5cb97956fe91c38338c3fc8f1e569dd8af36f6d12e32bf1460251d02eb WHIRLPOOL 88ec154f12ae95dcd1e570d5b6b0f23608153c558090654798abf60d0f78a911ed4583e67c0df2de5c872222ee43d68f2ec47f558002d91f9589989a1093c3c3
DIST libobjc2-1.8.tar.gz 173512 SHA256 b11957c58a08b97f314b410bcafaa4eacabdc417e8e865e5b802a621c3147bbe SHA512 1562e42dc43a24c1655d02db7aa101a48a7b026bec23252c8eec3893fbac0d67368685291df0954ee79f07b92ecc13c68ee7c7b0f351428a31e99ed05ed2230d WHIRLPOOL 7bbbfee09b1c4e24cc08a6d2b70449343d1245677e68023a374490e6bd2548fe39600a5c61c3e0534aacd338e775a200f37160f177f2fee197f5fd36ba0eaaa4
44 changes: 44 additions & 0 deletions gnustep-base/libobjc2/libobjc2-1.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit cmake-utils eutils

DESCRIPTION="GNUstep Objective-C runtime"
HOMEPAGE="http://www.gnustep.org"
SRC_URI="https://github.com/gnustep/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="boehm-gc cxx test"

RDEPEND="boehm-gc? ( dev-libs/boehm-gc )
cxx? ( sys-libs/libcxx )"
DEPEND="${DEPEND}
>=sys-devel/clang-2.9"

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.7-fix_soname.patch

if ! use cxx;
then
sed -e 's/addtest_flags(CXXExceptions.*//' \
-i Test/CMakeLists.txt || die "test sed failed"
fi
}

src_configure() {
export CC=clang
export CXX=clang++

export PREFIX=/usr
local mycmakeargs=(
-DGNUSTEP_CONFIG=GNUSTEP_CONFIG-NOTFOUND
$(cmake-utils_use boehm-gc BOEHM_GC)
$(cmake-utils_use_enable cxx OBJCXX)
$(cmake-utils_use test TESTS)
)
cmake-utils_src_configure
}

0 comments on commit 161b74a

Please sign in to comment.