Skip to content

Commit

Permalink
media-sound/karlyriceditor: introduce Qt 5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
Michael Palimaka committed Feb 19, 2016
1 parent bc6d29e commit 162c9cb
Show file tree
Hide file tree
Showing 2 changed files with 29 additions and 5 deletions.
12 changes: 12 additions & 0 deletions media-sound/karlyriceditor/files/karlyriceditor-2.1-qt55.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
Fix build with Qt 5.5

--- a/src/videoencodingprofiles.h
+++ b/src/videoencodingprofiles.h
@@ -21,6 +21,7 @@
#define VIDEOENCODINGPROFILES_H

#include <QMap>
+#include <QObject>
#include <QString>
#include <QStringList>

22 changes: 17 additions & 5 deletions media-sound/karlyriceditor/karlyriceditor-2.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -13,13 +13,20 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="libav"
IUSE="libav qt5"

RDEPEND="
dev-libs/openssl:0
dev-qt/qtcore:4
dev-qt/qtgui:4
media-libs/libsdl[sound]
qt5? (
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
)
!qt5? (
dev-qt/qtcore:4
dev-qt/qtgui:4
)
libav? ( media-video/libav:= )
!libav? ( media-video/ffmpeg:= )
"
Expand All @@ -30,10 +37,15 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.11-libav.patch"
"${FILESDIR}/${PN}-2.1-ffmpeg3.patch"
"${FILESDIR}/${PN}-2.1-qt55.patch"
)

src_configure() {
eqmake4 "${PN}.pro"
if use qt5; then
eqmake5 "${PN}.pro"
else
eqmake4 "${PN}.pro"
fi
}

src_install() {
Expand Down

0 comments on commit 162c9cb

Please sign in to comment.