Skip to content

Commit

Permalink
dev-db/libiodbc: new version 3.5.12.
Browse files Browse the repository at this point in the history
This new version comes with a few changes. Most noticeably, the ebuild
was updated to EAPI=6 and the eutils eclass was dropped. One patch
(fix-runpaths-r1.patch) had to be revisioned to make it compatible
with eapply.

Another patch, libiodbc-*-multilib.patch, had to be updated to apply
to the new version. I duplicated the additions/deletions in the
original patch exactly. Two other patches, libiodbc-3.52.7-gtk.patch
and libiodbc-3.52.8-gtk-parallel-make.patch, have become obsolete and
were removed completely.

I removed a "chmod -x include/*.h" hack, as it looks no longer
necessary. I then added a new hack, "touch ChangeLog" before
eautoreconf.

Gentoo-Bug: 516300

Package-Manager: portage-2.2.28
  • Loading branch information
orlitzky committed Aug 2, 2016
1 parent 8fea9a7 commit 1632e21
Show file tree
Hide file tree
Showing 4 changed files with 121 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/libiodbc/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libiodbc-3.52.12.zip 1248801 SHA256 3e764524538bf26ada27a8e55915d7ca42d5069e01d36ed57eabcb724d3764b4 SHA512 240f6f7dc406fcc6688499bac8800b81380d32e8443e4f098875fabc649da1b86567b67d2259206be64cced8537d3171040d16be39845b9009cd90be62ae97db WHIRLPOOL 782eec0afb4802abf6d2b3d293b0a886bdb8aa011676fc2814d7df02c14919c425b82cc7428495015fcdc14512a0aa887e5eb641b3eeb8372838e21e73a3e5dd
DIST libiodbc-3.52.8.zip 1188493 SHA256 f96cee2f04ab01b3c32297262ebf97b3faed1e49688399e656e8e4743ed72a0c SHA512 76da1e69a6e7ab1b7ba103547070c5dfe7c40fa88d82c243640d862c93c19e731d5a35d0575038491a148bb1d1cb7c5168dc30bf3f9600b31f4e014350f16551 WHIRLPOOL b6dafe709c3dff771ef43f023e62f528d92f9f9b05f0b986942826a2ded16e3cc2ccdae1606b2c31931ee487d01c25a173488c5e6d6c1ddafddb8f6be7dd326b
15 changes: 15 additions & 0 deletions dev-db/libiodbc/files/fix-runpaths-r1.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- a/samples/Makefile.am 2012-03-27 05:15:02.000000000 +0200
+++ b/samples/Makefile.am.new 2013-04-09 14:07:48.303789999 +0200
@@ -78,12 +78,10 @@
#
iodbctest_SOURCES = iodbctest.c
iodbctest_LDADD = ../iodbc/libiodbc.la
-iodbctest_LDFLAGS = -static

iodbctestw_CFLAGS = -DUNICODE
iodbctestw_SOURCES = iodbctest.c
iodbctestw_LDADD = ../iodbc/libiodbc.la
-iodbctestw_LDFLAGS = -static

EXTRA_DIST = $(srcdir)/Makefile.sample

37 changes: 37 additions & 0 deletions dev-db/libiodbc/files/libiodbc-3.52.12-multilib.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
diff --git a/bin/iodbc-config.in b/bin/iodbc-config.in
index 08d46ae..576aa8b 100644
--- a/bin/iodbc-config.in
+++ b/bin/iodbc-config.in
@@ -145,10 +145,10 @@ while test $# -gt 0; do
echo_libs=yes
;;
--static-libs)
- echo_staticlibs=yes
+ echo_libs=yes
;;
--libtool-libs)
- echo_libtoollibs=yes
+ echo_libs=yes
;;
--data-dir)
echo_data_dir=yes
@@ -196,19 +196,5 @@ if test "$echo_libs" = "yes"; then
if test "$lib_iodbc" = "yes"; then
libs="$libs -liodbc -liodbcinst"
fi
- echo "-L@libdir@ $libs"
-fi
-if test "$echo_staticlibs" = "yes"; then
- libs=""
- if test "$lib_iodbc" = "yes"; then
- libs="@libdir@/libiodbc.a @libdir@/libiodbcinst.a -lpthread @LIBADD_DL@"
- fi
- echo "$libs"
-fi
-if test "$echo_libtoollibs" = "yes"; then
- libs=""
- if test "$lib_iodbc" = "yes"; then
- libs="@libdir@/libiodbc.la @libdir@/libiodbcinst.la"
- fi
echo "$libs"
fi
68 changes: 68 additions & 0 deletions dev-db/libiodbc/libiodbc-3.52.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools multilib-minimal

MY_PN="iODBC"

DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.iodbc.org/"
SRC_URI="https://github.com/openlink/${MY_PN}/archive/v${PV}.zip -> ${P}.zip"

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
LICENSE="|| ( LGPL-2 BSD )"
SLOT="0"
IUSE="gtk"

RDEPEND="gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"

DOCS=( AUTHORS NEWS README )

S="${WORKDIR}/${MY_PN}-${PV}"

MULTILIB_CHOST_TOOLS=( /usr/bin/iodbc-config )

PATCHES=(
"${FILESDIR}"/libiodbc-3.52.12-multilib.patch
"${FILESDIR}"/libiodbc-3.52.7-debian_bug501100.patch
"${FILESDIR}"/libiodbc-3.52.7-debian_bug508480.patch
"${FILESDIR}"/libiodbc-3.52.7-unicode_includes.patch
"${FILESDIR}"/fix-runpaths-r1.patch
)

src_prepare() {
default
sed -i.orig \
-e '/^cd "$PREFIX"/,/^esac/d' \
iodbc/install_libodbc.sh || die "sed failed"

# Without this, automake dies. It's what upstream's autogen.sh does.
touch ChangeLog || die "failed to create empty ChangeLog"

eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" \
econf \
--disable-static \
--enable-odbc3 \
--enable-pthreads \
--with-layout=gentoo \
--with-iodbc-inidir=yes \
$(use_enable gtk gui)
}

multilib_src_install_all() {
einstalldocs
prune_libtool_files

# Install lintian overrides
insinto /usr/share/lintian/overrides
newins debian/iodbc.lintian-overrides iodbc
newins debian/libiodbc2.lintian-overrides libiodbc2
}

0 comments on commit 1632e21

Please sign in to comment.