Skip to content

Commit

Permalink
dev-vcs/gitolite-gentoo: bump
Browse files Browse the repository at this point in the history
Signed-off-by: Robin H. Johnson <[email protected]>
  • Loading branch information
robbat2 committed Jan 21, 2024
1 parent 9b3d473 commit 165a79c
Show file tree
Hide file tree
Showing 3 changed files with 110 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-vcs/gitolite-gentoo/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST 5df2b817255ee919991da6c310239e08c8fcc1ae.patch 4115 BLAKE2B 8f364eba7a1f3788ae6aacb76946d9cf963609ac3e6f093eedf4d5e17467eba0ceb88b5b4bbf3acc72ec17e6626f52836805ac07f6044d7712efcb499d0237ff SHA512 5098a82c860370edeec7c41cb71d0f10e6c03b3d1996f163e882d84ea64903d64e866bb67af45380f658870e2715cc805155380c96994854847b06a6db3e111d
DIST gitolite-gentoo-3.6.13.tar.bz2 169403 BLAKE2B 9eb628b92845a4ea5f36dce6b092568a70ceca8f6623854173f7d855502316aa77d458fb85e170f4c91d24167a3bc4ae9fd366a6c3925af3d42f1f597912f830 SHA512 6cf000750b652337ec728b23e1801fe8acc01cb8da9929cf797c3bbacc0246104a39ce204c2558e76ce1d3eda37fe4b15ef665827a8330745fc54bc193367bbc
DIST gitolite-gentoo-3.6.6.1.tar.bz2 155262 BLAKE2B 3dfa89223824ea04be6c0598abad3c6fb982c0031507aa2ab4ad8ecb9cfc5b64846e48f1710cf4436b4947d2f7288398b2603ac8f9a732902cf17a9a168e6b3d SHA512 76765972b06e985879bd3384be62e4b57676d0d67e6d55b56a63a2d802fe3ee76576e0da20896f11764a311dfcde0bfaf4309105ddc8c55c0c09bb098ed6a1bb
108 changes: 108 additions & 0 deletions dev-vcs/gitolite-gentoo/gitolite-gentoo-3.6.13.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,108 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

[[ ${PV} == *9999 ]] && SCM="git-2"
EGIT_REPO_URI="git://git.gentoo.org/proj/gitolite-gentoo"
EGIT_MASTER=master

inherit perl-module ${SCM}

DESCRIPTION="Highly flexible server for git directory version tracker, Gentoo fork"
HOMEPAGE="https://cgit.gentoo.org/fork/gitolite-gentoo.git/"

if [[ ${PV} != *9999 ]]; then
SRC_URI="http://dev.gentoo.org/~robbat2/distfiles/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="selinux tools vim-syntax"

DEPEND="
dev-lang/perl
>=dev-vcs/git-1.6.6
virtual/perl-File-Path
virtual/perl-File-Temp
"
RDEPEND="
${DEPEND}
acct-group/git
acct-user/git[gitolite]
>=dev-perl/Net-SSH-AuthorizedKeysFile-0.17
dev-perl/JSON
!dev-vcs/gitolite
vim-syntax? ( app-vim/gitolite-syntax )
selinux? ( sec-policy/selinux-gitosis )
"

PATCHES=(
)

src_prepare() {
default
echo "${PF}-gentoo" > src/VERSION || die
}

src_install() {
local uexec=/usr/libexec/${PN}

rm -rf src/lib/Gitolite/Test{,.pm}
insinto $VENDOR_LIB
doins -r src/lib/Gitolite

dodoc README.markdown CHANGELOG
# These are meant by upstream as examples, you are strongly recommended to
# customize them for your needs.
dodoc contrib/utils/ipa_groups.pl contrib/utils/ldap_groups.sh

insopts -m0755
insinto $uexec
doins -r src/{commands,syntactic-sugar,triggers,VREF}/
doins -r contrib/{commands,triggers,hooks}

insopts -m0644
doins src/VERSION

exeinto $uexec
doexe src/gitolite{,-shell}

dodir /usr/bin
for bin in gitolite{,-shell}; do
dosym ../libexec/${PN}/${bin} /usr/bin/${bin}
done

if use tools; then
dobin check-g2-compat convert-gitosis-conf
dobin contrib/utils/rc-format-v3.4
fi

fperms 0644 ${uexec}/VREF/MERGE-CHECK # It's meant as example only
}

pkg_postinst() {
local old_ver
for old_ver in ${REPLACING_VERSIONS}; do
if ver_test ${old_ver} -lt "3" ; then
ewarn
elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
elog "Please read http://gitolite.com/gitolite/migr.html first!"
ewarn
elog "***NOTE*** If you're using the \"umask\" feature of ${PN}-2.x:"
elog "You'll have to replace each \"umask = ...\" option by \"option umask = ...\""
elog "And you'll also have to enable the \"RepoUmask\" module in your .gitolite.rc"
ewarn
fi
done

# bug 352291
gitolite_home=$(awk -F: '$1 == "git" { print $6 }' /etc/passwd)
if [ -n "${gitolite_home}" -a "${gitolite_home}" != "/var/lib/gitolite" ]; then
ewarn
elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
elog "Especially if you're migrating from gitosis."
ewarn
fi
}
4 changes: 1 addition & 3 deletions dev-vcs/gitolite-gentoo/gitolite-gentoo-3.6.6.1-r3.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
Expand All @@ -16,8 +16,6 @@ if [[ ${PV} != *9999 ]]; then
SRC_URI="mirror://gentoo/${P}.tar.bz2"
SRC_URI+=" https://github.com/sitaramc/gitolite/commit/5df2b817255ee919991da6c310239e08c8fcc1ae.patch"
KEYWORDS="amd64 x86"
else
SRC_URI=""
fi

LICENSE="GPL-2"
Expand Down

0 comments on commit 165a79c

Please sign in to comment.