Skip to content

Commit

Permalink
dev-java/jal: EAPI 6 bump.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
monsieurp committed Mar 18, 2017
1 parent e0ac8c5 commit 16717a2
Showing 1 changed file with 50 additions and 0 deletions.
50 changes: 50 additions & 0 deletions dev-java/jal/jal-20031117-r5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

JAVA_PKG_IUSE="doc source"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="Partial port of the C++ Standard Template Library"
HOMEPAGE="http://vigna.dsi.unimi.it/jal"
SRC_URI="http://dev.gentoo.org/~monsieurp/packages/${P}.tar.gz"

LICENSE="HPND"
SLOT="0"
KEYWORDS="~amd64 ~x86"

CDEPEND="dev-java/ant-core:0"

RDEPEND="
${CDEPEND}
>=virtual/jre-1.6"

DEPEND="
${CDEPEND}
>=virtual/jdk-1.6"

S="${WORKDIR}/${P}"

JAVA_GENTOO_CLASSPATH="ant-core"

JAVA_SRC_DIR="src/jal"

src_prepare() {
default

# Generate sources.
./instantiate -n byte bytes || die
./instantiate -n short shorts || die
./instantiate -n char chars || die
./instantiate -n int ints || die
./instantiate -n long longs || die
./instantiate -n float floats || die
./instantiate -n double doubles || die
./instantiate Object objects || die
./instantiate String strings || die

mkdir -p src/jal || die
mv bytes shorts chars ints longs floats doubles objects strings src/jal || die
}

0 comments on commit 16717a2

Please sign in to comment.