Skip to content

Commit

Permalink
dev-util/buildbot-worker: Version bump, update 9999
Browse files Browse the repository at this point in the history
This version now enables full test suite operation.

Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
  • Loading branch information
dol-sen committed Jan 6, 2017
1 parent e1602f5 commit 1678cf1
Show file tree
Hide file tree
Showing 4 changed files with 136 additions and 7 deletions.
2 changes: 2 additions & 0 deletions dev-util/buildbot-worker/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST buildbot-worker-0.9.0.post1.tar.gz 95780 SHA256 9da22fdf23462680a37d3995cde75410f204d3cb417491363e3f6561fc9011b9 SHA512 50eb98ad4f870f15b1cc34113db139b3b290bef377b4f66ac7c023590f277c102b8776e3a009f296209cf524377c10f60435b18f47cc39d6c27af04778d3296e WHIRLPOOL 1dd5d4274281fe4f582b5e7b83a99693c41282cb2a5262b8899319d3a1e95888417174b8db4ed9f8dcd52ee66785adac98f0d2ecc8abc158a661dfdfa6cd33da
DIST buildbot-worker-0.9.1.tar.gz 65852 SHA256 1d8ec4fd51e7a3a7dd4de7c512b282c221951cbacc6b2eaf15a157f371a0e902 SHA512 cf5749c6fd67fb72cd7043392efb502608cd2d11374cd43af351904a1b4e82d790338e5f745b47465b5cbf9501d2454d983648a70246c6ae55603ba51261a0d0 WHIRLPOOL e576879f141688e3f79e3cf746491bcc106cb4851f14d4960b10be45b7b01c33c6850fb856d6f083d8510ff78f73016e11250e9ef8864e33bace1834c315dafc
DIST buildbot-worker-0.9.2.tar.gz 66043 SHA256 3d05791ac0c556e3e4fe0ef78911ce47eab4fcbb0b5a51a436234ba49b9c236e SHA512 146c2f2b0c44f5c349459edbe61b448e88f9e42eb1c3b7769a0a07260533e4ad40d2d7bc3df2ebecd355d636834108debe8c2d165a9cdc6d849a537cf5743cc4 WHIRLPOOL f786c3a7ac486a2421877082da08a73079b7655ec0941a9509663983c03874bc8b5c12cb990628d0684db757d493528fab9ea3d99d09c22f2d2bbf606c69d0b5
DIST buildbot_worker-9-tests.tar.xz 29512 SHA256 9966f1e368fae1ff05a4cdd801167b33fbad620acba79db21a5c28132dec61a3 SHA512 55aa3a5061ba0c9246e5029201a3565c6b20b198ccbf7ad3cad29599bdb8f883e8f33290f0f6fdb2e4a7c04f9132e32d762df8241cda8f689d407bb75d048122 WHIRLPOOL 9200d3676bf9fa56f36cc0bfc229250f6619512574696bde460ea0410462ac9fe030c5222145599ea1a792003c3ab0a8fc729c2294274e85665da47c81d03fb9
90 changes: 90 additions & 0 deletions dev-util/buildbot-worker/buildbot-worker-0.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,90 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
PYTHON_COMPAT=( python2_7 )

EGIT_REPO_URI="https://github.com/buildbot/buildbot.git"

[[ ${PV} == *9999 ]] && inherit git-r3
inherit readme.gentoo user distutils-r1

DESCRIPTION="BuildBot Slave Daemon"
HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"

MY_V="${PV/_p/p}"
MY_P="${PN}-${MY_V}"
if [[ ${PV} != *9999 ]]; then
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz
http://dev.gentoo.org/~dolsen/distfiles/buildbot_worker-9-tests.tar.xz"
fi

LICENSE="GPL-2"
SLOT="0"
if [[ ${PV} == *9999 ]]; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE="test"

RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
|| ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
>=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
)
dev-python/future[${PYTHON_USEDEP}]
!<dev-util/buildbot-0.9.0_rc1
"
DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/${MY_P}"
[[ ${PV} == *9999 ]] && S=${S}/slave

pkg_setup() {
enewuser buildbot

DOC_CONTENTS="The \"buildbot\" user and the \"buildbot_worker\" init script has been added
to support starting buildbot_worker through Gentoo's init system. To use this,
set up your build worker following the documentation, make sure the
resulting directories are owned by the \"buildbot\" user and point
\"${ROOT}etc/conf.d/buildbot_worker\" at the right location. The scripts can
run as a different user if desired. If you need to run more than one
build worker, just copy the scripts."
}

src_unpack() {
unpack ${MY_P}.tar.gz
cd ${MY_P}
unpack buildbot_worker-9-tests.tar.xz
}

src_prepare() {
epatch "${FILESDIR}"/buildbot-worker-0.9.Addmissedtests.patch
}

python_test() {
distutils_install_for_testing

esetup.py test || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all

doman docs/buildbot-worker.1

newconfd "${FILESDIR}/buildbot_worker.confd" buildslave
newinitd "${FILESDIR}/buildbot_worker.initd" buildslave

readme.gentoo_create_doc
}

pkg_postinst() {
readme.gentoo_print_elog
}
24 changes: 17 additions & 7 deletions dev-util/buildbot-worker/buildbot-worker-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

Expand All @@ -13,8 +13,7 @@ inherit readme.gentoo user distutils-r1
DESCRIPTION="BuildBot Slave Daemon"
HOMEPAGE="http://trac.buildbot.net/ http://code.google.com/p/buildbot/ http://pypi.python.org/pypi/buildbot-slave"

MY_PV="${PV/_p/p}"
MY_V="0.9.0rc1"
MY_V="${PV/_p/p}"
MY_P="${PN}-${MY_V}"
[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"

Expand All @@ -28,13 +27,18 @@ fi
IUSE="test"

RDEPEND=">=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
|| ( >=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
<dev-python/twisted-16.3.0[${PYTHON_USEDEP}]
|| ( >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
>=dev-python/twisted-core-8.0.0[${PYTHON_USEDEP}]
)
dev-python/future[${PYTHON_USEDEP}]
!<dev-util/buildbot-0.9.0_rc1"
!<dev-util/buildbot-0.9.0_rc1
"
DEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/setuptools_trial[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/${MY_P}"
[[ ${PV} == *9999 ]] && S=${S}/slave
Expand All @@ -51,6 +55,12 @@ pkg_setup() {
build worker, just copy the scripts."
}

python_test() {
distutils_install_for_testing

esetup.py test || die "Tests failed under ${EPYTHON}"
}

python_install_all() {
distutils-r1_python_install_all

Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 017f427a7c7959c11160a41e5987669f022e42c4 Mon Sep 17 00:00:00 2001
From: Brian Dolbec <[email protected]>
Date: Wed, 4 Jan 2017 19:01:12 -0800
Subject: [PATCH] worker/setup.py: Add missed tests

---
worker/setup.py | 4 ++++
1 file changed, 4 insertions(+)

diff --git a/worker/setup.py b/worker/setup.py
index f053a6226..cf004adbd 100755
--- a/worker/setup.py
+++ b/worker/setup.py
@@ -87,6 +87,10 @@ setup_args = {
"buildbot_worker.commands",
"buildbot_worker.scripts",
"buildbot_worker.monkeypatches",
+ "buildbot_worker.test",
+ "buildbot_worker.test.fake",
+ "buildbot_worker.test.unit",
+ "buildbot_worker.test.util",
],
# mention data_files, even if empty, so install_data is called and
# VERSION gets copied
--
2.11.0

0 comments on commit 1678cf1

Please sign in to comment.