Skip to content

Commit

Permalink
dev-ada/gtkada: Add gtkada-9999
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
atupone committed May 10, 2017
1 parent 4b09fb0 commit 16827c4
Show file tree
Hide file tree
Showing 5 changed files with 290 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/gtkada/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gtkada-17.0.tar.gz 5358097 SHA256 65298b7ce604963ab389d5577a2c71c0f0276b176d7387ac55195dc644b87449 SHA512 d2970d9cfb2c1a893e5fc146e41683583bcc70cfb744ba19e953fd00916488b39d96c59170c1d5272eb0b45deebcc906ec1be4a31d1141540a8feceb7b2cb034 WHIRLPOOL fd30280050ca42570509660c5afda2fbd3c463f016a0d8bee62f8d3e88e553600801fae00c97dd3a57ae0dc955fe1e3804250cdaa553a94d5316bb35b3f4cab8
DIST gtkada-gpl-2016-src.tgz 11944697 SHA256 263cc8323e726ae22946508792dd719ff266a9e847a4f7c95e27bd13d3fb4d8f SHA512 90912e15d9e22574a3d86e8bd052d4ce0a0d8018386f699dc1ce3c345978e9b3ddc7bdd3e4247a264496c5da7cff6ae68589a02f43193fc957c418e2a8ef63c7 WHIRLPOOL fc12f151c65ccef5d23b520cfc0625606ece06e56ed2d5b28e39bd65e51850d9b5c40e7382207f1d9186f93ce9232f6024bec977af6973163eb6603178dc1a30
85 changes: 85 additions & 0 deletions dev-ada/gtkada/files/gtkada-17.0-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
--- gtkada-gpl-2015-src/shared.gpr.in.old 2017-01-05 23:28:35.838073270 +0100
+++ gtkada-gpl-2015-src/shared.gpr.in 2017-01-05 23:30:17.752255709 +0100
@@ -44,6 +44,8 @@
for Switches ("C") use ("-O2");
end case;

+ for Driver ("C") use External ("CC", "gcc");
+ for PIC_Option ("C") use ("-fPIC");
for Switches ("C") use Compiler'Switches ("C") & Gtk_Include;
for Switches ("Objective-C") use Compiler'Switches ("Objective-C") & Gtk_Include;
end Compiler;
--- gtkada-gpl-2016-src/Makefile.in.old 2017-01-21 22:42:18.319969095 +0100
+++ gtkada-gpl-2016-src/Makefile.in 2017-01-21 22:42:33.989700236 +0100
@@ -39,7 +39,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-datadir=@datadir@
+datadir=$(DESTDIR)@datadir@
datarootdir=@datarootdir@
exampledir=${datadir}/examples/gtkada/testgtk

@@ -60,30 +60,33 @@
LIBRARY_TYPE_FOR_TOOLS=static
endif

-all: tools tests
+all: tools
static: build_library_type/static
relocatable: build_library_type/relocatable

tools:
@echo "====== Building tools ====="
- ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) -Psrc/tools/tools.gpr
+ ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
+ -Psrc/tools/tools.gpr -cargs:Ada $(ADAFLAGS)

build_library_type/%: src/gtkada-intl.adb
@echo "====== Building $(@F) libraries ====="
- ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/gtkada.gpr
+ ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/gtkada.gpr \
+ -cargs:Ada $(ADAFLAGS) -cargs:C $(CFLAGS)
ifeq (${HAVE_OPENGL}, True)
${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/opengl/gtkada_gl.gpr
endif

src/gtkada-intl.adb: src/gtkada-intl.gpb Makefile
- gnatprep -DGETTEXT_INTL=$(GETTEXT_INTL) -DHAVE_GETTEXT=$(HAVE_GETTEXT) src/gtkada-intl.gpb $@
+ $(GNATPREP) -DGETTEXT_INTL=$(GETTEXT_INTL) -DHAVE_GETTEXT=$(HAVE_GETTEXT) src/gtkada-intl.gpb $@

testgtk/opengl/view_gl.adb: testgtk/opengl/view_gl.gpb Makefile
- gnatprep -r -c -DHAVE_GL=${HAVE_OPENGL} -DWIN32=False testgtk/opengl/view_gl.gpb $@
+ $(GNATPREP) -r -c -DHAVE_GL=${HAVE_OPENGL} -DWIN32=False testgtk/opengl/view_gl.gpb $@

tests: testgtk/opengl/view_gl.adb
@echo "====== Building tests ====="
- cd testgtk; ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) -Ptestgtk.gpr -aP ../src
+ cd testgtk; ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
+ -Ptestgtk.gpr -aP ../src -cargs:Ada $(ADAFLAGS)

install/%: force
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(@F) --build-name=$(@F) \
@@ -96,7 +96,7 @@
ifeq (${HAVE_OPENGL}, True)
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(@F) --build-name=$(@F) \
--sources-subdir=include/gtkada/gtkada_gl.$(@F) \
- --lib-subdir=${libdir}/gtkada/gtkada_gl.$(@F) \
+ --lib-subdir=lib/gtkada/gtkada_gl.$(@F) \
-Psrc/opengl/gtkada_gl.gpr
endif

@@ -118,12 +118,9 @@
--project-subdir=lib/gnat gtkada
endif

-install: install-clean
+install:
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
--mode=usage -Psrc/tools/tools.gpr
- cd testgtk; ${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
- --mode=usage --exec-subdir=${DESTDIR}${exampledir} \
- -Ptestgtk.gpr -aP ../src

@echo '-----------------------------------------------------------------------'
@echo '-- GtkAda has now been installed. --'
76 changes: 76 additions & 0 deletions dev-ada/gtkada/files/gtkada-9999-gentoo.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
--- gtkada-gpl-2015-src/shared.gpr.in.old 2017-01-05 23:28:35.838073270 +0100
+++ gtkada-gpl-2015-src/shared.gpr.in 2017-01-05 23:30:17.752255709 +0100
@@ -44,6 +44,8 @@
for Switches ("C") use ("-O2");
end case;

+ for Driver ("C") use External ("CC", "gcc");
+ for PIC_Option ("C") use ("-fPIC");
for Switches ("C") use Compiler'Switches ("C") & Gtk_Include;
for Switches ("Objective-C") use Compiler'Switches ("Objective-C") & Gtk_Include;
end Compiler;
--- gtkada-gpl-2016-src/Makefile.in.old 2017-01-21 22:42:18.319969095 +0100
+++ gtkada-gpl-2016-src/Makefile.in 2017-01-21 22:42:33.989700236 +0100
@@ -39,7 +39,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
libdir=@libdir@
-datadir=@datadir@
+datadir=$(DESTDIR)@datadir@
datarootdir=@datarootdir@
exampledir=${datadir}/examples/gtkada/testgtk

@@ -60,30 +60,33 @@
LIBRARY_TYPE_FOR_TOOLS=static
endif

-all: tools tests
+all: tools
static: build_library_type/static
relocatable: build_library_type/relocatable

tools:
@echo "====== Building tools ====="
- ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) -Psrc/tools/tools.gpr
+ ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
+ -Psrc/tools/tools.gpr -cargs:Ada $(ADAFLAGS)

build_library_type/%: src/gtkada-intl.adb
@echo "====== Building $(@F) libraries ====="
- ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/gtkada.gpr
+ ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/gtkada.gpr \
+ -cargs:Ada $(ADAFLAGS) -cargs:C $(CFLAGS)
ifeq (${HAVE_OPENGL}, True)
${GPRBUILD_FULL} -XLIBRARY_TYPE=$(@F) -Psrc/opengl/gtkada_gl.gpr
endif

src/gtkada-intl.adb: src/gtkada-intl.gpb Makefile
- gnatprep -DGETTEXT_INTL=$(GETTEXT_INTL) -DHAVE_GETTEXT=$(HAVE_GETTEXT) src/gtkada-intl.gpb $@
+ $(GNATPREP) -DGETTEXT_INTL=$(GETTEXT_INTL) -DHAVE_GETTEXT=$(HAVE_GETTEXT) src/gtkada-intl.gpb $@

testgtk/opengl/view_gl.adb: testgtk/opengl/view_gl.gpb Makefile
- gnatprep -r -c -DHAVE_GL=${HAVE_OPENGL} -DWIN32=False testgtk/opengl/view_gl.gpb $@
+ $(GNATPREP) -r -c -DHAVE_GL=${HAVE_OPENGL} -DWIN32=False testgtk/opengl/view_gl.gpb $@

tests: testgtk/opengl/view_gl.adb
@echo "====== Building tests ====="
- cd testgtk; ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) -Ptestgtk.gpr -aP ../src
+ cd testgtk; ${GPRBUILD_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
+ -Ptestgtk.gpr -aP ../src -cargs:Ada $(ADAFLAGS)

install/%: force
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(@F) --build-name=$(@F) \
@@ -118,12 +118,9 @@
--project-subdir=lib/gnat gtkada
endif

-install: install-clean
+install:
${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
--mode=usage -Psrc/tools/tools.gpr
- cd testgtk; ${GPRINSTALL_FULL} -XLIBRARY_TYPE=$(LIBRARY_TYPE_FOR_TOOLS) \
- --mode=usage --exec-subdir=${DESTDIR}${exampledir} \
- -Ptestgtk.gpr -aP ../src

@echo '-----------------------------------------------------------------------'
@echo '-- GtkAda has now been installed. --'
64 changes: 64 additions & 0 deletions dev-ada/gtkada/gtkada-17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools multiprocessing

DESCRIPTION="A complete Ada graphical toolkit"
HOMEPAGE="http://libre.adacore.com//tools/gtkada/"
SRC_URI="https://github.com/AdaCore/gtkada/archive/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="+shared static"

RDEPEND="dev-lang/gnat-gpl
dev-libs/atk
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/pango"
DEPEND="${RDEPEND}
dev-ada/gprbuild"

S="${WORKDIR}"/${PN}-${P}

PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

pkg_setup() {
GCC=${ADA:-$(tc-getCC)}
export GNATPREP="${GCC/gcc/gnatprep}"
if [[ -z "$(type ${GNATPREP} 2>/dev/null)" ]] ; then
eerror "You need a gcc compiler that provides the Ada Compiler:"
eerror "1) use gcc-config to select the right compiler or"
eerror "2) set ADA=gcc-4.9.4 in make.conf"
die "ada compiler not available"
fi
}

src_prepare() {
default
mv configure.{in,ac}
eautoreconf
}

src_configure() {
econf \
$(use_enable static) \
$(use_enable shared) \
--without-GL
}

src_compile() {
emake -j1 PROCESSORS=$(makeopts_jobs)
}

src_install() {
emake -j1 DESTDIR="${D}" install
einstalldocs
}
64 changes: 64 additions & 0 deletions dev-ada/gtkada/gtkada-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit autotools multiprocessing git-r3

DESCRIPTION="A complete Ada graphical toolkit"
HOMEPAGE="http://libre.adacore.com//tools/gtkada/"
SRC_URI=""

LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="+shared static"

RDEPEND="dev-lang/gnat-gpl
dev-libs/atk
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/pango"
DEPEND="${RDEPEND}
dev-ada/gprbuild"

EGIT_REPO_URI="https://github.com/AdaCore/gtkada.git"

PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

pkg_setup() {
GCC=${ADA:-$(tc-getCC)}
export GNATPREP="${GCC/gcc/gnatprep}"
if [[ -z "$(type ${GNATPREP} 2>/dev/null)" ]] ; then
eerror "You need a gcc compiler that provides the Ada Compiler:"
eerror "1) use gcc-config to select the right compiler or"
eerror "2) set ADA=gcc-4.9.4 in make.conf"
die "ada compiler not available"
fi
}

src_prepare() {
default
mv configure.{in,ac}
eautoreconf
}

src_configure() {
econf \
$(use_enable static) \
$(use_enable shared) \
--without-GL
}

src_compile() {
emake -j1 PROCESSORS=$(makeopts_jobs)
}

src_install() {
emake -j1 DESTDIR="${D}" install
einstalldocs
}

0 comments on commit 16827c4

Please sign in to comment.