Skip to content

Commit

Permalink
dev-util/pycharm-professional: Version bump (bug 589840).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
xmw committed Aug 19, 2016
1 parent 8100a3b commit 16880b3
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/pycharm-professional/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pycharm-professional-2016.1.3.tar.gz 265376721 SHA256 c29d407cc81b0d2afb590e2c55305bf1ea48b5afcf865336a14bbabd7089c0e6 SHA512 f8e301bd327485c3f309e4e71029c781ffdc26e0878a110178a8238617158487512b134b2d4031111fd64f4b40901e0e35988809977dc04c498cbfdf5274826d WHIRLPOOL 10500fe010196beeece19cd2c3982aaa117e6d3085d468411361c5213f98d3ebbc785352838d52600894d30ce40ee40211d41315853dcc370a3fd5b56da2cbff
DIST pycharm-professional-2016.1.4.tar.gz 265023084 SHA256 47323791c67105b2ce57a531d8965915186b9f19f4e234e65c4b3dca31c87333 SHA512 14fba6e4f633abee0dea0f128bb9cd54085a7b12a725a62d4d16aacb5617de42f70c6c64d3fe63442919382723f89a55ca92192ff99682f8052861ff4eaf593e WHIRLPOOL 5b8f4141769958ca6f3822cb04d82f573f1ee79aa13701259998777e24076cee90579b2d2247b9cd18d187d2a90ecbe762b7a6eb6330c65533d2690feffcd4c0
DIST pycharm-professional-2016.2.1.tar.gz 269669263 SHA256 95a63e07ba0ff884bf963b30e25ebf3903322066841cf18695fead5bec77a1be SHA512 4d4340f9af5368836a0b50352cebf95cad09605298bff93515a436faef57c28b66dd2e1cf09a1a80e6bff7434a4185bf8e8064c5f87429bcd549ada71a6d5fa5 WHIRLPOOL 4e4d81a8315cce4f3a2c8947cd448436f86af9841208f7234008522c6c077a6ec265a6f7c6288a9ecceafae5656d3fcba4e5f8190c291a18f2b81a09e4d927ca
39 changes: 39 additions & 0 deletions dev-util/pycharm-professional/pycharm-professional-2016.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit eutils readme.gentoo-r1

DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"

LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND=">=virtual/jre-1.8
dev-python/pip"
DEPEND=""

RESTRICT="mirror strip"
QA_PREBUILT="*"

MY_PN=${PN/-professional/}
S="${WORKDIR}/${MY_PN}-${PV}"

src_install() {
insinto /opt/${PN}
doins -r *

fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}

dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
newicon "bin/${MY_PN}.png" ${PN}.png
make_desktop_entry ${PN} "${PN}" "${PN}"

readme.gentoo_create_doc
}

0 comments on commit 16880b3

Please sign in to comment.