Skip to content

Commit

Permalink
app-crypt/easy-rsa: Version bump
Browse files Browse the repository at this point in the history
Gentoo-Bug: 515634

Package-Manager: portage-2.2.27
  • Loading branch information
mrueg committed Feb 2, 2016
1 parent 161be59 commit 169cce0
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/easy-rsa/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST EasyRSA-2.2.2.tgz 10492 SHA256 68da869085dde7c6a964e9c6104b86e4af91c4c592f8ec2a2f6cfc9d20808991 SHA512 b09bd1a71c1bfeb3c2ff63f10b7781badf6d2b4888d97d917565436435b85fb90eebf7727db293bdc44039f23c7f3c3c4e762a22bf7d6e9ed7642a2f07e1ffe4 WHIRLPOOL 27b7d761a317d8787526dbdc1878e62326e6ca13730ddf9b50fe918f010c23d1535dfa4f6bfb76bf26bd005942105a0e862359579faf7b6fe803ad7ca53d627e
DIST EasyRSA-3.0.1.tgz 40960 SHA256 dbdaf5b9444b99e0c5221fd4bcf15384c62380c1b63cea23d42239414d7b2d4e SHA512 d20f646e33ec803444dfcd446553f1d6001227fedec93280c212b34cccee11b184599f1b2ae6a3ce9cf6c9ac52f2b840ebb645536df6ddf55382fa25c22df81f WHIRLPOOL 64d54af059e136409f4ad3488450cccc846e2b5d9dfb9e002dd466cf603b6677dc8f0b788471b73eebda918c5773673efc120e6a76dbf407a3e1605db14e62cd
35 changes: 35 additions & 0 deletions app-crypt/easy-rsa/easy-rsa-3.0.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils

MY_P="EasyRSA-${PV}"

DESCRIPTION="Small RSA key management package, based on OpenSSL"
HOMEPAGE="http://openvpn.net/"
SRC_URI="https://github.com/OpenVPN/easy-rsa/releases/download/${PV}/${MY_P}.tgz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="libressl"

DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
libressl? ( dev-libs/libressl )"
RDEPEND="${DEPEND}
!<net-misc/openvpn-2.3"

S="${WORKDIR}/${MY_P}"

src_install() {
exeinto /usr/share/easy-rsa
doexe easyrsa
insinto /usr/share/easy-rsa
doins vars.example openssl-1.0.cnf x509-types
dodoc README.quickstart.md ChangeLog
dodoc -r doc
doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
}

0 comments on commit 169cce0

Please sign in to comment.