Skip to content

Commit

Permalink
dev-python/PyContracts: Bump to 1.8.14
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 18, 2020
1 parent 410ead4 commit 169e61f
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/PyContracts/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST PyContracts-1.7.9.tar.gz 61033 BLAKE2B 5202d39c91d7dff6e07058f3f7dcc29baa750f69ed9b4abb059de67f3be98e568270eb3d977a6e7a18f232880225fcc532fbd576e94dc3483bde9b8fbe68d526 SHA512 1db6491d4be3df96753dcdd6f85329d47409a2424177a52d1e35f5a1d58f671290d22d807b70f632f0376c86c58c093118f7223b7ad59893a85dccdb91d29f50
DIST PyContracts-1.8.0.tar.gz 90577 BLAKE2B 988662274e3bbea1ede6d00f4a69b3eb23dad439f5355a9b0a2c5a2f76a6250254303b060ef720d13d9a297ded77f7713271a79a810227aa883dc6d4d46ea725 SHA512 7de933dc8b5992be670b4b34fce7d6f51769d3d2dd02a2400eff5991e9e686e36791234588d2dbdeccf437fd5d6abc6461240645e6d3f665394f390bb727413a
DIST PyContracts-1.8.12.tar.gz 91393 BLAKE2B 083c836a547540f2505cbc02c8696ad2ae236a9ba46529cc60d237c01bd113cb5a9d2729a70038e28f4a6f776cb17b119bdf9ae8dcd6269cbcd05412413aa758 SHA512 9abd5ab5203687ddd8a738998e63e8f3e397b9ba9b9ee22bda945dab4f0d460115ed8e825c9c551d4c067b0f39dbb5b8ca51d365623b10ee8e210efc4edcbf15
DIST PyContracts-1.8.14.tar.gz 92346 BLAKE2B 507fdfb313347d6650f21326b6b70b73f17cd702f25d06d97e5d84f84c9bf7f23cceb48d918727158d02081115344a4194e307caed59510265dacbf267774ab4 SHA512 95f8c76e35cc7549fefa069d9c354fc1d4a55dcab0f3fd322cb86aed92c7bfa75a06eabb7540ff991d590a90cdec781906b856291002a82ee5ab0072cdcf6ccd
32 changes: 32 additions & 0 deletions dev-python/PyContracts/PyContracts-1.8.14.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )

inherit distutils-r1

DESCRIPTION="Declare constraints on function parameters and return values"
HOMEPAGE="https://andreacensi.github.com/contracts/ https://pypi.org/project/PyContracts/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"

RDEPEND="
dev-python/decorator[${PYTHON_USEDEP}]
dev-python/future[${PYTHON_USEDEP}]
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"

distutils_enable_tests nose

python_test() {
nosetests -v \
$(python_is_python3 || echo "--ignore-files=test_py3k_annotations.py") \
|| die
}

0 comments on commit 169e61f

Please sign in to comment.