Skip to content

Commit

Permalink
media-libs/jasper: Add live ebuild
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.2
  • Loading branch information
SoapGentoo committed Oct 18, 2016
1 parent 748ff96 commit 16bf550
Showing 1 changed file with 48 additions and 0 deletions.
48 changes: 48 additions & 0 deletions media-libs/jasper/jasper-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,48 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools git-r3 multilib-minimal

DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
HOMEPAGE="http://www.ece.uvic.ca/~mdadams/jasper/"
EGIT_REPO_URI="https://github.com/mdadams/jasper.git"

LICENSE="JasPer2.0"
SLOT="0/1"
KEYWORDS=""
IUSE="jpeg opengl static-libs"

RDEPEND="
jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
opengl? (
>=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
>=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
virtual/glu
)"
DEPEND="${RDEPEND}
app-arch/unzip"

PATCHES=( "${FILESDIR}/${PN}-1.900.6-fix-build-system.patch" )

src_prepare() {
default
eautoreconf
}

multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable jpeg libjpeg) \
$(use_enable opengl) \
$(use_enable static-libs static)
}

multilib_src_install_all() {
einstalldocs
dodoc -r doc/.

# package provides .pc files
find "${D}" -name '*.la' -delete || die
}

0 comments on commit 16bf550

Please sign in to comment.