forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-doc/kicad-doc: Add 4.0.5 ebuild, move to EAPI6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
- Loading branch information
Showing
2 changed files
with
70 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kicad-doc-4.0.1.tar.gz 23365382 SHA256 be8dc4bddb89869996956d3d1421584c5a8197282997902e22fda888a8d433bb SHA512 ae57a9c29f3cd4b3d85d4b7d7bc940957c33b0e1c1404b82c8a9261695c0670866cb4a95ab7ad5c35b1faa6fbd3969f277467fa7d33e38e728a3dd9b65203021 WHIRLPOOL d9834312a0a315bf1d5dca048999d5adcb2ee60c42a41d8266522ad6c0ca49ec7bad5c9bad322b6d73c41c9f24cb1f4088d6889c6a51abf4671271dd7ec8af9d | ||
DIST kicad-doc-4.0.4.tar.gz 33705865 SHA256 5564217076641926a2523d4dc66e78810de2fe4b5bd4d2f0ba40a522203c4d27 SHA512 97a45ebbd11ab7f92eff1409bc03512b7685fb4a85dd1d87675e92742cc6672a1332c5fe8d63577eba93ed976af1bb4acaa461dbada5e4695a161cefa82c9ff4 WHIRLPOOL be03128787fc9461e9220845a42acd6d7a6bac5adfdc3106365e8c46e7bd185b6a25857b66c91d444a13a03184fb3a260d04d156768304bddb577ce8e776676a | ||
DIST kicad-doc-4.0.5.tar.gz 47074652 SHA256 fa1dac9b491a0e4863fc6fffba1ad8a610ad8a8b5552885f76f73407ed5b740f SHA512 2705d5cb92ba7ae5535bcefc89016fbbf6b7936b458b3ea06446177285fd4a2d93cbb54e042d9b1e8953ad3e9c56e817f5729af956a7b1435d53a7c085da1bdb WHIRLPOOL 91bc796fd135006a48640c40937843400e7a7e41f2d4b6baf4dd4b2beea20704966d9e761d976d402607e0a9cb2a5f037173413c57c12d57afb0743eb7ab7828 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,69 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils | ||
|
||
DESCRIPTION="Electronic Schematic and PCB design tools manuals" | ||
HOMEPAGE="http://www.kicad-pcb.org/" | ||
SRC_URI="https://github.com/KiCad/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="|| ( GPL-3+ CC-BY-3.0 ) GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="html +pdf" | ||
LANGS="en fr it ja nl pl" | ||
for lang in ${LANGS}; do | ||
LUSE+=" l10n_${lang}" | ||
done | ||
IUSE+=${LUSE} | ||
REQUIRED_USE="|| ( html pdf ) ^^ ( ${LUSE} )" | ||
unset lang | ||
unset LUSE | ||
|
||
DEPEND=">=app-text/asciidoc-8.6.9 | ||
app-text/dblatex | ||
app-text/texlive:=[l10n_en?,l10n_fr?,l10n_it?,l10n_ja?,l10n_nl?,l10n_pl?] | ||
>=app-text/po4a-0.45 | ||
>=sys-devel/gettext-0.18 | ||
dev-util/source-highlight | ||
dev-perl/Unicode-LineBreak | ||
l10n_ja? ( media-fonts/vlgothic )" | ||
RDEPEND="" | ||
|
||
src_prepare() { | ||
DOCPATH="KICAD_DOC_INSTALL_PATH share/doc/kicad" | ||
sed "s|${DOCPATH}|${DOCPATH}-${PV}|g" -i CMakeLists.txt || die "sed failed" | ||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local formats="" | ||
local doclang="" | ||
local format lang | ||
|
||
# construct format string | ||
for format in html pdf; do | ||
use ${format} && formats+="${format};" | ||
done | ||
|
||
# find out which language is requested | ||
for lang in ${LANGS}; do | ||
if use l10n_${lang}; then | ||
if [[ -z ${doclang} ]]; then | ||
doclang="${lang}" | ||
else | ||
ewarn "Only one single language can be enabled." \ | ||
"Using \"${doclang}\", ignoring \"${lang}\"." | ||
fi | ||
fi | ||
done | ||
|
||
local mycmakeargs=( | ||
-DBUILD_FORMATS="${formats}" | ||
-DSINGLE_LANGUAGE="${doclang}" | ||
) | ||
cmake-utils_src_configure | ||
} |