Skip to content

Commit

Permalink
app-misc/mc: add HTML highlighting fixes, bug #542982
Browse files Browse the repository at this point in the history
Patch by Raymond Jennings.

Reported-by: Raymond Jennings
Bug: https://bugs.gentoo.org/542982

Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Sergei Trofimovich committed Jan 22, 2017
1 parent 9ecdc3f commit 16f2e2e
Show file tree
Hide file tree
Showing 2 changed files with 133 additions and 0 deletions.
29 changes: 29 additions & 0 deletions app-misc/mc/files/mc-4.8.18-html.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
commit 6b656100ac907636f0b54b12921408260a9fd583
Author: Raymond Jennings <[email protected]>
Date: Fri Oct 7 22:38:07 2016 +0200

mcedit: syntax: fix mismatched highlighting for <{o,u}l> HTML tags

Signed-off-by: Raymond Jennings <[email protected]>
Signed-off-by: Yury V. Zaytsev <[email protected]>

diff --git a/misc/syntax/html.syntax b/misc/syntax/html.syntax
index 2b3afd30e..3adbe4d0b 100644
--- a/misc/syntax/html.syntax
+++ b/misc/syntax/html.syntax
@@ -52,6 +52,7 @@ context default
keyword </SMALL> brightcyan/17
keyword </SCRIPT> brightcyan/17
keyword </META> brightcyan/17
+ keyword </OL> brightcyan/17
keyword </P> brightcyan/17
keyword </TABLE> brightcyan/17
keyword </TD> brightcyan/17
@@ -59,6 +60,7 @@ context default
keyword </TR> brightcyan/17
keyword </TT> brightcyan/17
keyword </U> brightcyan/17
+ keyword </UL> brightcyan/17


context <A > brightcyan/17
104 changes: 104 additions & 0 deletions app-misc/mc/mc-4.8.18-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,104 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils flag-o-matic

MY_P=${P/_/-}

DESCRIPTION="GNU Midnight Commander is a text based file manager"
HOMEPAGE="http://www.midnight-commander.org"
SRC_URI="http://ftp.midnight-commander.org/${MY_P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
IUSE="+edit gpm mclib nls samba sftp +slang spell test X +xdg"

REQUIRED_USE="spell? ( edit )"

RDEPEND=">=dev-libs/glib-2.26.0:2
gpm? ( sys-libs/gpm )
kernel_linux? ( sys-fs/e2fsprogs )
samba? ( net-fs/samba )
sftp? ( net-libs/libssh2 )
slang? ( >=sys-libs/slang-2 )
!slang? ( sys-libs/ncurses:0= )
spell? ( app-text/aspell )
X? ( x11-libs/libX11
x11-libs/libICE
x11-libs/libXau
x11-libs/libXdmcp
x11-libs/libSM )"
DEPEND="${RDEPEND}
app-arch/xz-utils
virtual/pkgconfig
nls? ( sys-devel/gettext )
test? ( dev-libs/check )
"

PATCHES=(
"${FILESDIR}"/${PN}-4.8.13-tinfo.patch
"${FILESDIR}"/${P}-html.patch
)

S=${WORKDIR}/${MY_P}

src_prepare() {
[[ -n ${LIVE_EBUILD} ]] && ./autogen.sh

default

eautoreconf
}

src_configure() {
local myscreen=ncurses
use slang && myscreen=slang
[[ ${CHOST} == *-solaris* ]] && append-ldflags "-lnsl -lsocket"

local homedir=".mc"
use xdg && homedir="XDG"

econf \
--disable-silent-rules \
--disable-dependency-tracking \
$(use_enable nls) \
--enable-vfs \
$(use_enable kernel_linux vfs-undelfs) \
--enable-charset \
$(use_with X x) \
$(use_enable samba vfs-smb) \
$(use_enable sftp vfs-sftp) \
$(use_enable spell aspell) \
$(use_with gpm gpm-mouse) \
--with-screen=${myscreen} \
$(use_with edit internal-edit) \
$(use_enable mclib) \
$(use_enable test tests) \
--with-homedir=${homedir}
}

src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS README NEWS

# fix bug #334383
if use kernel_linux && [[ ${EUID} == 0 ]] ; then
fowners root:tty /usr/libexec/mc/cons.saver
fperms g+s /usr/libexec/mc/cons.saver
fi

if ! use xdg ; then
sed 's@MC_XDG_OPEN="xdg-open"@MC_XDG_OPEN="/bin/false"@' \
-i "${ED}"/usr/libexec/mc/ext.d/*.sh || die
fi
}

pkg_postinst() {
elog "To enable exiting to latest working directory,"
elog "put this into your ~/.bashrc:"
elog ". ${EPREFIX}/usr/libexec/mc/mc.sh"
}

0 comments on commit 16f2e2e

Please sign in to comment.