Skip to content

Commit

Permalink
dev-python/pybind11: Bump to 2.10.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jan 4, 2023
1 parent bd6819b commit 16fb4e0
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/pybind11/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST pybind11-2.10.0.gh.tar.gz 716362 BLAKE2B d9d3a8a108a303721766b822d43b631396c451c8caea0ec1bd36a97850382cdaec69a4f4e5fb475bc84e2aead050f73b759320a81750a661997870e1a84383b5 SHA512 93112ce530a0652b2b4458a137b4a35f2fd8607f82ad96698ef422128d0b53e16e1d06c239ee4643b821acafae09c74eb0f72bc4ee5584aa9fcdaff4d79980d9
DIST pybind11-2.10.1.gh.tar.gz 727880 BLAKE2B d051220f33ce44ea6d174d64a2ecfad4f7452b0f5152035cfd36950875dc451e11e8352eb80c9c01b200176c0b09fa5274504ece524e699590deac64c44d57c6 SHA512 040f109ec870516acdaebc5133ccbba9e3ed7ff93214a66997cf4b8366c209322f3c902c283040826c7e585c3ea2259caf62d90d0b475bfa33d21e459dd54df1
DIST pybind11-2.10.2.gh.tar.gz 739436 BLAKE2B 19d1182f61202b63f3cddcef427a6a4f38329d96932a3882c12a10eb6a6bb725723fe48862d2b0370ea4ddd2bc5675de4c9a680a4f2d28d6bd6e58d0fe5c8848 SHA512 051c2608c37612e857c00ac48429d1c26c14336f20988fb447df25b345b28c5b97ccb80f4227c54de4ef2bd4f8ea3d550acc4a5bb2dd86d65dc1915fdca36719
DIST pybind11-2.10.3.gh.tar.gz 740214 BLAKE2B 967b93cbf7d1f8faad25db9a4d3e84fd33b48429cdf527c167e65faad5c01df83a5634021cf99f07adf443855d9f6bb076f0cc67b0e6555e189b794a845b533a SHA512 3894400f04cd08e2dbb14b3d696339f0364434f1d6f8bb057338ac88157ec7491b2df1e1e46ebd5abccdcd5775c5e9238de6404f0db87f64f5a1802db3a5b18c
DIST pybind11-2.9.2.tar.gz 709521 BLAKE2B 76ae9c72faad805885eabbe4dadf1092fe814f04f2a8d834da035c7389dcc996c09a63149911aa7a5c0b70d2da9f7c32e94aaf1c941f13345e0aef40a5748dfc SHA512 c6c18e5f59873adb3692640ade26472abd257607e7bb9fd48cfd1949878811e83d6ac6eb8c8dd926622d52ca4f13e5e6a58e0abaaaa1fa814ee831ea2b515272
67 changes: 67 additions & 0 deletions dev-python/pybind11/pybind11-2.10.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )

inherit cmake distutils-r1

DESCRIPTION="AST-based Python refactoring library"
HOMEPAGE="
https://pybind11.readthedocs.io/en/stable/
https://github.com/pybind/pybind11/
https://pypi.org/project/pybind11/
"
SRC_URI="
https://github.com/pybind/pybind11/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
dev-cpp/eigen:3
"
BDEPEND="
test? (
>=dev-cpp/catch-2.13.5
dev-libs/boost
)
"

distutils_enable_tests pytest

python_prepare_all() {
export PYBIND11_USE_CMAKE=1
cmake_src_prepare
distutils-r1_python_prepare_all
}

python_configure() {
local mycmakeargs=(
# disable forced lto
-DPYBIND11_LTO_CXX_FLAGS=
-DPYBIND11_INSTALL=ON
-DPYBIND11_TEST=$(usex test)
)
cmake_src_configure
}

python_compile() {
distutils-r1_python_compile
# Compilation only does anything for tests
use test && cmake_src_compile
}

python_test() {
cmake_build check
}

python_install() {
distutils-r1_python_install
cmake_src_install
}

0 comments on commit 16fb4e0

Please sign in to comment.