forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/gstreamer-editing-services: bump to 1.14.1, drop wrong gno…
…nlin dep gst-editing-services hasn't been using libgnl for a while now. Closes: https://bugs.gentoo.org/636304 Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
55 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST gstreamer-editing-services-1.12.3.tar.xz 1061796 BLAKE2B 250983e470a607f5734a1dde799223521f3918f2c985ddc9995f4a9720e7ce7147a60f9d90b71be65f06f3caf7fe0428d90a7f9395f31930f06fc18b9710ce36 SHA512 18f2ae1e04e5848221f45728b5d4002549aeaaeaa39af58410666fbc6ab01971900fabaa92cc3d17f910c4d4d5dc691689aeb7930164a24a6b9c49709e7fb669 | ||
DIST gstreamer-editing-services-1.12.4.tar.xz 1062972 BLAKE2B e2f401e419e793a37b3deac71696326f6d2c7491d7a138c40de8af46f2bd5ba415b56b9656a9d225d9704e3339b15aee3e587299441c2b75633a7792a954d4b3 SHA512 b845fc897384aaf691a9dcbf26e6ba682c9eca161e0ad227f47fb0865527d05254fd7b08d082e824a026bfe6909efe8069e3205e209a2e6dfce07f5a7d18dfdf | ||
DIST gstreamer-editing-services-1.14.1.tar.xz 1059888 BLAKE2B d176c5d4341df208ee87d71f1838e5bb6c3bce7f072a3214d6907b91e75a81f5cd79cf424266205641281d525dea7e36423ffb98adef3cddd54814ea763a8d00 SHA512 3801769a515f248b923c50ad51961175094a66f2aa55184e82ecb948331c05b6e297a723d5443db11ec3274ee48f56d6dcc8af8a95cf9e701cc4e02615f8e6e4 |
54 changes: 54 additions & 0 deletions
54
media-libs/gstreamer-editing-services/gstreamer-editing-services-1.14.1.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,54 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
PYTHON_COMPAT=( python2_7 python3_{4,5,6} ) | ||
|
||
inherit bash-completion-r1 gnome2 python-r1 | ||
|
||
DESCRIPTION="SDK for making video editors and more" | ||
HOMEPAGE="http://wiki.pitivi.org/wiki/GES" | ||
SRC_URI="https://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz" | ||
|
||
LICENSE="LGPL-2+" | ||
SLOT="1.0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
IUSE="+introspection" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
RDEPEND=" | ||
${PYTHON_DEPS} | ||
>=dev-libs/glib-2.40.0:2 | ||
dev-libs/libxml2:2 | ||
dev-python/pygobject:3[${PYTHON_USEDEP}] | ||
>=media-libs/gstreamer-${PV}:1.0[introspection?] | ||
>=media-libs/gst-plugins-base-${PV}:1.0[introspection?] | ||
introspection? ( >=dev-libs/gobject-introspection-0.9.6:= ) | ||
" | ||
DEPEND="${RDEPEND} | ||
>=dev-util/gtk-doc-am-1.3 | ||
virtual/pkgconfig | ||
" | ||
# XXX: tests do pass but need g-e-s to be installed due to missing | ||
# AM_TEST_ENVIRONMENT setup. | ||
RESTRICT="test" | ||
|
||
src_configure() { | ||
# gtk is only used for examples | ||
gnome2_src_configure \ | ||
$(use_enable introspection) \ | ||
--disable-examples \ | ||
--without-gtk \ | ||
--with-bash-completion-dir="$(get_bashcompdir)" \ | ||
--with-package-name="GStreamer editing services ebuild for Gentoo" \ | ||
--with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer-editing-services" | ||
} | ||
|
||
src_compile() { | ||
# Prevent sandbox violations, bug #538888 | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=744135 | ||
# https://bugzilla.gnome.org/show_bug.cgi?id=744134 | ||
addpredict /dev | ||
gnome2_src_compile | ||
} |