Skip to content

Commit

Permalink
dev-cpp/string-theory: version bump to 3.4
Browse files Browse the repository at this point in the history
Signed-off-by: Richard Fröhning <[email protected]>
Closes: gentoo#19228
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
misanthropos authored and juippis committed Feb 3, 2021
1 parent 5a03197 commit 174c34b
Show file tree
Hide file tree
Showing 2 changed files with 39 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-cpp/string-theory/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST string-theory-3.3.tar.gz 588360 BLAKE2B ad87857e6d5e3cad1346b759457b434de7612b97e1b19016b1dfc987ac67f0cab318745b14fe1f432cc921ffb1d33b875a2a62f0bc56d815dd35b405a9f08560 SHA512 86209333dce341078c3b973084bd9f3b8ff2ccac0e07a5e6acf5973bd1cfa420897b531b2d1bd6aba9f5ccc8927f85d91f06796ac0e62ec8a735564a0387d2f4
DIST string-theory-3.4.tar.gz 588522 BLAKE2B 207c490293401829d28590291166bcbeefde4ecb3b70d1cc2751d7582c53cf234b7e01579d3bfbe55681708e4d3e22cedbd6fe96b2fdad1c3ef158bb7a080593 SHA512 36ad82c6da276b7cb66d350ceb4bed2a66f768a6604b2981331ceec6a96d03cc3a7e7e5f733de88ec15e0ea41f99f8657b959a51149c540f530d06268c5657ff
38 changes: 38 additions & 0 deletions dev-cpp/string-theory/string-theory-3.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake

DESCRIPTION="A flexible modern C++ library for string manipulation and storage"
HOMEPAGE="https://github.com/zrax/string_theory/"
SRC_URI="https://github.com/zrax/string_theory/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/string_theory-${PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
RESTRICT="!test? ( test )"

src_prepare() {
# Drop -Werror from bundled gtest
# bug #766468
sed -i -e "s/-Werror//" test/gtest-1.10.0/cmake/internal_utils.cmake || die

cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
-DST_BUILD_TESTS=$(usex test)
)

cmake_src_configure
}

src_test() {
cd "${BUILD_DIR}/test" || die
./st_gtests || die
}

0 comments on commit 174c34b

Please sign in to comment.