Skip to content

Commit

Permalink
app-admin/kpcli: add 4.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Mair-Keimberger <[email protected]>
Closes: gentoo#36946
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
mm1ke authored and ConiKost committed Jun 22, 2024
1 parent 1517a3d commit 174e334
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/kpcli/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST kpcli-3.8.1.pl 263292 BLAKE2B 70e9e4ca56466e51314e891de2282f9124c7eedd0f7aea7abfc4ad94a1f4ebcc4d65dc09573560e4cc90be4a2f4a3156d6d4e57f3cb5a27de297fca137fc9cbb SHA512 5d4ba12112b6b82dc150193f6c2210c868c6582726cf157f05d2ad74224ac6f637d09075ae410ce91481b222cc1f40c3fb2f6267923a04a06211929d92a05097
DIST kpcli-4.1.pl 366041 BLAKE2B 71a3814981a3ebfc9a9d784bab5706ff58796e84f8f58472da9f1f800b63a6ade4c8b8e334a1f118c4783d19f27c5d0af5b0bbaeb75d1cb6337967a3ac2a7f33 SHA512 54352fee32b381a73ab65bd8743115e867883a731d23722dde1102803579349fde130f8ffd23904996125f4d23cd4709dc0416ba668efa8a569cb64ee883ca8f
43 changes: 43 additions & 0 deletions app-admin/kpcli/kpcli-4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit optfeature

DESCRIPTION="Command line interface to KeePass database files"
HOMEPAGE="https://kpcli.sourceforge.io/"
SRC_URI="https://downloads.sourceforge.net/project/kpcli/${P}.pl"

LICENSE="|| ( Artistic GPL-1+ )"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="dev-perl/Clone
dev-perl/Crypt-Rijndael
dev-perl/File-KeePass
dev-perl/Math-Random-ISAAC
dev-perl/Sort-Naturally
dev-perl/Sub-Install
dev-perl/TermReadKey
dev-perl/Term-ReadLine-Gnu
dev-perl/Term-ShellUI"

src_unpack() {
mkdir "${S}" || die
cp "${DISTDIR}/${P}.pl" "${S}/${PN}" || die
}

src_compile() { :; }

src_install() {
dobin kpcli
}

pkg_postinst() {
optfeature "time-based-one-time-only password support" "dev-perl/Authen-OATH dev-perl/Convert-Base32"
optfeature "X clipboard support" "dev-perl/Capture-Tiny dev-perl/Clipboard"
optfeature "password quality check" dev-perl/Data-Password
optfeature "better password quality check" dev-perl/Data-Password-passwdqc
optfeature "importing Password Safe v3 databases" dev-perl/Crypt-PWSafe3
}

0 comments on commit 174e334

Please sign in to comment.