Skip to content

Commit

Permalink
sys-apps/portage: Bump to version 2.3.84
Browse files Browse the repository at this point in the history
 #690436 limit scope of dropped circular dependencies, which should
         solve some cases of bug 199856 such as bug 703676 (also see
         tracker bug 689644)

Bug: https://bugs.gentoo.org/701268
Bug: https://bugs.gentoo.org/199856
Bug: https://bugs.gentoo.org/689644
Bug: https://bugs.gentoo.org/690436
Bug: https://bugs.gentoo.org/703676
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Dec 26, 2019
1 parent a056fc0 commit 1793a98
Show file tree
Hide file tree
Showing 2 changed files with 277 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-apps/portage/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST portage-2.3.76.tar.bz2 1033462 BLAKE2B 1be0641337cd7d2a55f8aaba6f84bbfa7182
DIST portage-2.3.79.tar.bz2 1038675 BLAKE2B 7a6cff28fa1d4b54607e9416914ab534d250718b082a9789a36be057933867a8a3befd7c99d404b058f67b92c6ee975323c37251fe89d3e3e46865daf0fea25e SHA512 23101644185fb7c6eff12f015d442599b3af744f7b13dcb630f47a7f27c1392c46bd4aa5fa32d403dcf058cc3cc1d56cef00fd8c34dda811388eb268761c0797
DIST portage-2.3.82.tar.bz2 1042836 BLAKE2B 97fc32b988863497564f64bb22ecdb787f6d6075ec3f5a35c27f7c8b0610892c0516236eba238deec59ee5f9c42e0f10c6ef6c9a2f193ff54e24d86706afd814 SHA512 cee59744bba8bb429689dde899df2d84a42ac68b1e0f4a65f8f14c6db04a26a805095b54a807fa95dfe4032e8a637660a9aec88f70b36ba785228ed0db9c1144
DIST portage-2.3.83.tar.bz2 1043583 BLAKE2B aaeaae19c9ec677f2c35451a4c223dbe26c696b2742e186e45512ef75484deeb55f9127a040c3aa389b1d66ffba9c0c6fb30e86b6977a16c7f46adaf86d1f671 SHA512 172dcbd6383918c83b370164d7b6e0e0039250b15d48db0a7e616afaf29ecd2490d6f2ef3b2b68c7138f475c802f7e147255bf50459565ca328233e0e1d5ae67
DIST portage-2.3.84.tar.bz2 1043069 BLAKE2B 85ccc209011ef5206e0aaf768ec0276449f5a691f62f8dd65b812b6a285030796180acce89e9f2c8ae05fe4f59505133535f0374bf076846f819477d0a62d231 SHA512 49797ded65091ea7450f3c37e4ca1efb4205bc67e873295b5060ee6d39c1c63313fc1caa8c2f6c7afa6b352cef6d7ef04b8371c66a3ade05ac734b46f807bfd7
276 changes: 276 additions & 0 deletions sys-apps/portage/portage-2.3.84.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,276 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=(
pypy
python3_5 python3_6 python3_7 python3_8
python2_7
)
PYTHON_REQ_USE='bzip2(+),threads(+)'

inherit distutils-r1 linux-info systemd prefix

DESCRIPTION="Portage is the package management and distribution system for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
SLOT="0"
IUSE="build doc epydoc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"

DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
>=app-arch/tar-1.27
dev-lang/python-exec:2
>=sys-apps/sed-4.0.5 sys-devel/patch
doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
epydoc? (
$(python_gen_cond_dep '
>=dev-python/epydoc-2.0[${PYTHON_USEDEP}]
' 'python2*')
)"
# Require sandbox-2.2 for bug #288863.
# For xattr, we can spawn getfattr and setfattr from sys-apps/attr, but that's
# quite slow, so it's not considered in the dependencies as an alternative to
# to python-3.3 / pyxattr. Also, xattr support is only tested with Linux, so
# for now, don't pull in xattr deps for other kernels.
# For whirlpool hash, require python[ssl] (bug #425046).
# For compgen, require bash[readline] (bug #445576).
# app-portage/gemato goes without PYTHON_USEDEP since we're calling
# the executable.
RDEPEND="
>=app-arch/tar-1.27
dev-lang/python-exec:2
!build? (
>=sys-apps/sed-4.0.5
app-shells/bash:0[readline]
>=app-admin/eselect-1.2
$(python_gen_cond_dep 'dev-python/pyblake2[${PYTHON_USEDEP}]' \
python{2_7,3_5} pypy)
rsync-verify? (
>=app-portage/gemato-14[${PYTHON_USEDEP}]
>=app-crypt/openpgp-keys-gentoo-release-20180706
>=app-crypt/gnupg-2.2.4-r2[ssl(-)]
)
)
elibc_FreeBSD? ( sys-freebsd/freebsd-bin )
elibc_glibc? ( >=sys-apps/sandbox-2.2 )
elibc_musl? ( >=sys-apps/sandbox-2.2 )
elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
kernel_linux? ( sys-apps/util-linux )
>=app-misc/pax-utils-0.1.17
selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
xattr? ( kernel_linux? (
>=sys-apps/install-xattr-0.3
$(python_gen_cond_dep 'dev-python/pyxattr[${PYTHON_USEDEP}]' \
python2_7 pypy)
) )
!<app-admin/logrotate-3.8.0
!<app-portage/gentoolkit-0.4.6
!<app-portage/repoman-2.3.10"
PDEPEND="
!build? (
>=net-misc/rsync-2.6.4
userland_GNU? ( >=sys-apps/coreutils-6.4 )
)"
# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
# NOTE: FEATURES=installsources requires debugedit and rsync

REQUIRED_USE="epydoc? ( $(python_gen_useflags 'python2*') )"

SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"

prefix_src_archives() {
local x y
for x in ${@}; do
for y in ${SRC_ARCHIVES}; do
echo ${y}/${x}
done
done
}

TARBALL_PV=${PV}
SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
$(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)"

pkg_pretend() {
local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS"

check_extra_config
}

pkg_setup() {
use epydoc && DISTUTILS_ALL_SUBPHASE_IMPLS=( python2.7 )
}

python_prepare_all() {
distutils-r1_python_prepare_all

if use gentoo-dev; then
einfo "Disabling --dynamic-deps by default for gentoo-dev..."
sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
-i lib/_emerge/create_depgraph_params.py || \
die "failed to patch create_depgraph_params.py"

einfo "Enabling additional FEATURES for gentoo-dev..."
echo 'FEATURES="${FEATURES} strict-keepdir"' \
>> cnf/make.globals || die
fi

if use native-extensions; then
printf "[build_ext]\nportage-ext-modules=true\n" >> \
setup.cfg || die
fi

if ! use ipc ; then
einfo "Disabling ipc..."
sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
-i lib/_emerge/AbstractEbuildProcess.py || \
die "failed to patch AbstractEbuildProcess.py"
fi

if use xattr && use kernel_linux ; then
einfo "Adding FEATURES=xattr to make.globals ..."
echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
|| die "failed to append to make.globals"
fi

if use build || ! use rsync-verify; then
sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
-e '/^sync-webrsync-verify-signature/s|yes|no|' \
-i cnf/repos.conf || die "sed failed"
fi

if [[ -n ${EPREFIX} ]] ; then
einfo "Setting portage.const.EPREFIX ..."
hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
-w "/_BINARY/" lib/portage/const.py

einfo "Prefixing shebangs ..."
while read -r -d $'\0' ; do
local shebang=$(head -n1 "$REPLY")
if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
die "sed failed"
fi
done < <(find . -type f ! -name etc-update -print0)

einfo "Adjusting make.globals, repos.conf and etc-update ..."
hprefixify cnf/{make.globals,repos.conf} bin/etc-update

if use prefix-guest ; then
sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
-e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
-e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
-i cnf/repos.conf || die "sed failed"
fi

einfo "Adding FEATURES=force-prefix to make.globals ..."
echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
|| die "failed to append to make.globals"
fi

cd "${S}/cnf" || die
if [ -f "make.conf.example.${ARCH}".diff ]; then
patch make.conf.example "make.conf.example.${ARCH}".diff || \
die "Failed to patch make.conf.example"
else
eerror ""
eerror "Portage does not have an arch-specific configuration for this arch."
eerror "Please notify the arch maintainer about this issue. Using generic."
eerror ""
fi
}

python_compile_all() {
local targets=()
use doc && targets+=( docbook )
use epydoc && targets+=( epydoc )

if [[ ${targets[@]} ]]; then
esetup.py "${targets[@]}"
fi
}

python_test() {
esetup.py test
}

python_install() {
# Install sbin scripts to bindir for python-exec linking
# they will be relocated in pkg_preinst()
distutils-r1_python_install \
--system-prefix="${EPREFIX}/usr" \
--bindir="$(python_get_scriptdir)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
--portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
--sbindir="$(python_get_scriptdir)" \
--sysconfdir="${EPREFIX}/etc" \
"${@}"
}

python_install_all() {
distutils-r1_python_install_all

local targets=()
use doc && targets+=(
install_docbook
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
)
use epydoc && targets+=(
install_epydoc
--htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
)

# install docs
if [[ ${targets[@]} ]]; then
esetup.py "${targets[@]}"
fi

systemd_dotmpfilesd "${FILESDIR}"/portage-ccache.conf

# Due to distutils/python-exec limitations
# these must be installed to /usr/bin.
local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
einfo "Moving admin scripts to the correct directory"
dodir /usr/sbin
for target in ${sbin_relocations}; do
einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
done
}

pkg_preinst() {
python_setup
python_export PYTHON_SITEDIR
[[ -d ${D%/}${PYTHON_SITEDIR} ]] || die "${D%/}${PYTHON_SITEDIR}: No such directory"
env -u DISTDIR \
-u PORTAGE_OVERRIDE_EPREFIX \
-u PORTAGE_REPOSITORIES \
-u PORTDIR \
-u PORTDIR_OVERLAY \
PYTHONPATH="${D%/}${PYTHON_SITEDIR}${PYTHONPATH:+:${PYTHONPATH}}" \
"${PYTHON}" -m portage._compat_upgrade.default_locations || die

# elog dir must exist to avoid logrotate error for bug #415911.
# This code runs in preinst in order to bypass the mapping of
# portage:portage to root:root which happens after src_install.
keepdir /var/log/portage/elog
# This is allowed to fail if the user/group are invalid for prefix users.
if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
fi

if has_version "<${CATEGORY}/${PN}-2.3.77"; then
elog "The emerge --autounmask option is now disabled by default, except for"
elog "portions of behavior which are controlled by the --autounmask-use and"
elog "--autounmask-license options. For backward compatibility, previous"
elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
elog "Users can get the old behavior simply by adding --autounmask to the"
elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
elog "change, see https://bugs.gentoo.org/658648."
fi
}

0 comments on commit 1793a98

Please sign in to comment.