forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
- Loading branch information
Showing
2 changed files
with
173 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gtk-vnc-0.7.1.tar.xz 444380 BLAKE2B bad577dbc759f824d0ef342572363314d493cfcf7822db6356c6766422ecc46cc890ef54167bd3e215bb56a5059a2014c1c28b6e63c2451b21e5a923d7005cf1 SHA512 5d62f60e1c9fe70f93a9d21c529145459f0d59d588631597d533ecba94864271d1095599db9447ac4843814be61af7a7c947f69e5a9cd26db7e811f2c4e95f0c | ||
DIST gtk-vnc-0.7.2.tar.xz 447088 BLAKE2B 539cc9214735cf73c6e578029b33892c3e2d0d1dc402f82fa6d8d107c9a410e551020d9201192b69e50b75bb8297919ab0961752251dcf0bd75823d7426e01b5 SHA512 b95b1da6ff512c466feaa6efc831e9c36c5a77390b518c647c60fddda9dd850eea8658174682ae135b95bfca7bf2b4e85a5e5ac9adb43e3ddd7aa690288655ce |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,172 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
PYTHON_COMPAT=( python2_7 ) | ||
VALA_MIN_API_VERSION="0.16" | ||
VALA_USE_DEPEND="vapigen" | ||
|
||
inherit gnome2 multibuild python-r1 vala | ||
|
||
DESCRIPTION="VNC viewer widget for GTK" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/gtk-vnc" | ||
|
||
LICENSE="LGPL-2.1+" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd" | ||
IUSE="examples +gtk3 +introspection pulseaudio python sasl vala" | ||
REQUIRED_USE=" | ||
python? ( ${PYTHON_REQUIRED_USE} ) | ||
vala? ( gtk3 introspection ) | ||
" | ||
|
||
# libview is used in examples/gvncviewer -- no need | ||
# glib-2.30.1 needed to avoid linking failure due to .la files (bug #399129) | ||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.30.1:2 | ||
>=dev-libs/libgcrypt-1.4.2:0= | ||
dev-libs/libgpg-error | ||
>=net-libs/gnutls-3.0:0= | ||
>=x11-libs/cairo-1.2 | ||
>=x11-libs/gtk+-2.18:2 | ||
x11-libs/libX11 | ||
gtk3? ( >=x11-libs/gtk+-2.91.3:3[introspection?] ) | ||
introspection? ( >=dev-libs/gobject-introspection-0.9.4:= ) | ||
pulseaudio? ( media-sound/pulseaudio ) | ||
python? ( | ||
${PYTHON_DEPS} | ||
>=dev-python/pygtk-2:2[${PYTHON_USEDEP}] ) | ||
sasl? ( dev-libs/cyrus-sasl ) | ||
" | ||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
DEPEND="${COMMON_DEPEND} | ||
>=dev-lang/perl-5 | ||
>=dev-util/intltool-0.40 | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
vala? ( | ||
$(vala_depend) | ||
>=dev-libs/gobject-introspection-0.9.4 ) | ||
" | ||
# eautoreconf requires gnome-common | ||
|
||
compute_variants() { | ||
MULTIBUILD_VARIANTS=( 2.0 ) | ||
use gtk3 && MULTIBUILD_VARIANTS+=( 3.0 ) | ||
} | ||
|
||
src_prepare() { | ||
prepare() { | ||
mkdir -p "${BUILD_DIR}" || die | ||
|
||
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then | ||
python_foreach_impl prepare | ||
fi | ||
} | ||
|
||
local MULTIBUILD_VARIANTS | ||
compute_variants | ||
multibuild_foreach_variant prepare | ||
|
||
# Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk, upstream bug#744393 | ||
sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \ | ||
-i src/Makefile.* || die | ||
|
||
vala_src_prepare | ||
gnome2_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local myconf=( | ||
$(use_with examples) | ||
$(use_enable introspection) | ||
$(use_with pulseaudio) | ||
$(use_with sasl) | ||
--with-coroutine=gthread | ||
--without-libview | ||
--disable-static | ||
--disable-vala | ||
) | ||
|
||
configure_python() { | ||
ECONF_SOURCE="${S}" gnome2_src_configure \ | ||
${myconf[@]} \ | ||
--with-gtk=2.0 \ | ||
--with-python | ||
} | ||
|
||
configure_normal() { | ||
ECONF_SOURCE="${S}" gnome2_src_configure \ | ||
${myconf[@]} \ | ||
--with-gtk=${MULTIBUILD_VARIANT} \ | ||
--without-python | ||
|
||
# for gtk3, python support is via gobject-introspection | ||
# Ex: from gi.repository import GtkVnc | ||
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then | ||
python_foreach_impl run_in_build_dir configure_python | ||
fi | ||
} | ||
|
||
local MULTIBUILD_VARIANTS | ||
compute_variants | ||
multibuild_foreach_variant run_in_build_dir configure_normal | ||
} | ||
|
||
src_compile() { | ||
compile_python() { | ||
cd "${BUILD_DIR}"/src || die | ||
# CPPFLAGS set to help find includes for gvnc.override | ||
emake gtkvnc.la \ | ||
VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \ | ||
CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src" \ | ||
gtkvnc_la_LIBADD="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" \ | ||
gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" | ||
} | ||
|
||
compile_normal() { | ||
gnome2_src_compile | ||
|
||
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then | ||
local GTK2_BUILDDIR="${BUILD_DIR}" | ||
python_foreach_impl run_in_build_dir compile_python | ||
fi | ||
} | ||
|
||
local MULTIBUILD_VARIANTS | ||
compute_variants | ||
multibuild_foreach_variant run_in_build_dir compile_normal | ||
} | ||
|
||
src_test() { | ||
local MULTIBUILD_VARIANTS | ||
compute_variants | ||
|
||
multibuild_foreach_variant run_in_build_dir default | ||
} | ||
|
||
src_install() { | ||
install_python() { | ||
cd "${BUILD_DIR}"/src || die | ||
emake install-pyexecLTLIBRARIES DESTDIR="${D}" \ | ||
VPATH="${S}/src:${GTK2_BUILDDIR}/src:${BUILD_DIR}/src" \ | ||
CPPFLAGS="${CPPFLAGS} -I${GTK2_BUILDDIR}/src" \ | ||
gtkvnc_la_LIBADD="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" \ | ||
gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la" | ||
} | ||
|
||
install_normal() { | ||
gnome2_src_install | ||
|
||
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then | ||
local GTK2_BUILDDIR="${BUILD_DIR}" | ||
python_foreach_impl run_in_build_dir install_python | ||
fi | ||
} | ||
|
||
local MULTIBUILD_VARIANTS | ||
compute_variants | ||
multibuild_foreach_variant run_in_build_dir install_normal | ||
} |