Skip to content

Commit

Permalink
dev-ada/gprconfig_kb: add gcc_13 support
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Nov 6, 2023
1 parent 349dd73 commit 17c13e4
Showing 1 changed file with 39 additions and 0 deletions.
39 changes: 39 additions & 0 deletions dev-ada/gprconfig_kb/gprconfig_kb-23.0.0-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )

inherit ada

DESCRIPTION="GPR configuration knowledge base"
HOMEPAGE="https://www.adacore.com/"
SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

REQUIRED_USE="${ADA_REQUIRED_USE}"
PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )

src_prepare() {
default

sed -i \
-e "s:@VER@:${GCC_PV}:g" \
db/compilers.xml \
db/gnat.xml \
db/c.xml \
db/linker.xml \
|| die
}

src_install() {
insinto /usr/share/gprconfig
doins db/*.xml
doins db/*.ent
einstalldocs
}

0 comments on commit 17c13e4

Please sign in to comment.