Skip to content

Commit

Permalink
dev-python/setuptools_scm: Add python3.5 support
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Oct 11, 2015
1 parent 9259ad9 commit 17c7017
Showing 1 changed file with 26 additions and 0 deletions.
26 changes: 26 additions & 0 deletions dev-python/setuptools_scm/setuptools_scm-1.8.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="package to manage versions by scm tags via setuptools"
HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

python_test() {
py.test -v -v -x || die "tests failed under ${EPYTHON}"
}

0 comments on commit 17c7017

Please sign in to comment.