Skip to content

Commit

Permalink
dev-vcs/qgit: Fix build with Qt 5.11
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.29, Repoman-2.3.9
  • Loading branch information
a17r committed Apr 17, 2018
1 parent 3c3186b commit 17c9422
Show file tree
Hide file tree
Showing 3 changed files with 107 additions and 0 deletions.
51 changes: 51 additions & 0 deletions dev-vcs/qgit/files/qgit-2.7-highdpi-support.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
From e60ae49271e06384163afa1ebd1e562eb7c520ed Mon Sep 17 00:00:00 2001
From: David Edmundson <[email protected]>
Date: Thu, 15 Feb 2018 17:39:22 +0000
Subject: [PATCH] Add high DPI support

---
src/listview.cpp | 11 ++++++++++-
src/qgit.cpp | 5 ++++-
2 files changed, 14 insertions(+), 2 deletions(-)

diff --git a/src/listview.cpp b/src/listview.cpp
index dd6a8cb..e4f094e 100644
--- a/src/listview.cpp
+++ b/src/listview.cpp
@@ -884,7 +884,16 @@ void ListViewDelegate::addTextPixmap(QPixmap** pp, SCRef txt, const QStyleOption
int pw = fm.boundingRect(txt).width() + 2 * spacing;
int ph = fm.height();

- QPixmap* newPm = new QPixmap(ofs + pw, ph);
+ QSize pixmapSize(ofs + pw, ph);
+
+#if QT_VERSION >= QT_VERSION_CHECK(5,6,0)
+ qreal dpr = qApp->devicePixelRatio();
+ QPixmap* newPm = new QPixmap(pixmapSize * dpr);
+ newPm->setDevicePixelRatio(dpr);
+#else
+ QPixmap* newPm = new QPixmap(pixmapSize);
+#endif
+
QPainter p;
p.begin(newPm);
if (!pm->isNull()) {
diff --git a/src/qgit.cpp b/src/qgit.cpp
index 266a7b8..b01c49e 100644
--- a/src/qgit.cpp
+++ b/src/qgit.cpp
@@ -18,7 +18,10 @@ using namespace QGit;
int main(int argc, char* argv[]) {

QApplication app(argc, argv);
- QCoreApplication::setOrganizationName(ORG_KEY);
+#if QT_VERSION >= QT_VERSION_CHECK(5,6,0)
+ app.setAttribute(Qt::AA_UseHighDpiPixmaps, true);
+#endif
+ QCoreApplication::setOrganizationName(ORG_KEY);
QCoreApplication::setApplicationName(APP_KEY);

/* On Windows msysgit exec directory is set up
--
2.15.1

24 changes: 24 additions & 0 deletions dev-vcs/qgit/files/qgit-2.7-qt-5.11.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
From 563bc3ab3f928a3ba1c22e5e62ab8cbe15c6bc15 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <[email protected]>
Date: Tue, 17 Apr 2018 13:28:19 +0200
Subject: [PATCH] Fix build with Qt 5.11 (missing header)

---
src/patchview.cpp | 1 +
1 file changed, 1 insertion(+)

diff --git a/src/patchview.cpp b/src/patchview.cpp
index 5e3765d..afa796e 100644
--- a/src/patchview.cpp
+++ b/src/patchview.cpp
@@ -6,6 +6,7 @@
Copyright: See COPYING file that comes with this distribution

*/
+#include <QButtonGroup>
#include <QScrollBar>
#include "common.h"
#include "git.h"
--
2.17.0

32 changes: 32 additions & 0 deletions dev-vcs/qgit/qgit-2.7-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="Qt GUI for git repositories"
HOMEPAGE="http://libre.tibirna.org/projects/qgit/wiki/QGit"
SRC_URI="https://github.com/tibirna/qgit/archive/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE=""

DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
RDEPEND="${DEPEND}
dev-vcs/git
!dev-vcs/qgit:2
"

S=${WORKDIR}/${PN}-${P}

PATCHES=(
"${FILESDIR}/${P}-highdpi-support.patch"
"${FILESDIR}/${P}-qt-5.11.patch"
)

0 comments on commit 17c9422

Please sign in to comment.