Skip to content

Commit

Permalink
net-analyzer/goaccess: add 1.9.3
Browse files Browse the repository at this point in the history
Signed-off-by: Vladimir Pavljuchenkov <[email protected]>
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
SpiderX authored and juippis committed Jul 18, 2024
1 parent 42f0da4 commit 17da9d0
Show file tree
Hide file tree
Showing 3 changed files with 74 additions and 1 deletion.
1 change: 1 addition & 0 deletions net-analyzer/goaccess/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST goaccess-1.8.1.tar.gz 740177 BLAKE2B cc1f17c72adeeaf50d3b6c7bef47a044a3bbf06fb44d73da9b1ae68ea71d8e276dbe02c6a89cf0a72f3327e817e8d59235f788d29aeb7c7c889bacf81b64292a SHA512 96f0b73f13cfb77ad57748bce7d8791f8486bfd5ce47420d1c0016826a4deb9ab2d2742f4afd5d8b0eed003f9b596aae51f232fa71bf47f823b6ff8119f91354
DIST goaccess-1.9.3.tar.gz 821878 BLAKE2B 99a3a0f9b73a24bb871df2eb16be44dfefbe8fdcd9f10aec66beca98bae65a8b98085c58168c35407f53cf599cf33bc930247f7f7241742ca7750ef68236992e SHA512 6f838d006bec65819d42115b9ce6edb3d839c1bbb609353163960361684ae67c5ecb859e5c9e19eb3233aac4e97c18bdd4d19e1919b05695b3dfef3ca5e7a192
3 changes: 2 additions & 1 deletion net-analyzer/goaccess/files/goaccess.initd
Original file line number Diff line number Diff line change
@@ -1,12 +1,13 @@
#!/sbin/openrc-run
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

command="/usr/bin/goaccess"
name="GoAccess"
description="Real-time web log analyzer"
config="${CONFIG:-/etc/goaccess/goaccess.conf}"
command_args="--real-time-html --daemonize -p $config ${OPTS}"
pidfile="/run/goaccess/${RC_SVCNAME}.pid"
start_stop_daemon_args="-q"

depend() {
Expand Down
71 changes: 71 additions & 0 deletions net-analyzer/goaccess/goaccess-1.9.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# shellcheck disable=SC2207

EAPI=8

inherit autotools optfeature systemd tmpfiles

DESCRIPTION="A real-time web log analyzer and interactive viewer in a terminal"
HOMEPAGE="https://goaccess.io"
SRC_URI="https://tar.goaccess.io/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug geoip geoipv2 getline ssl unicode"
REQUIRED_USE="geoipv2? ( geoip )"

RDEPEND="acct-group/goaccess
acct-user/goaccess
sys-libs/ncurses:=[unicode(+)?]
geoip? (
!geoipv2? ( dev-libs/geoip )
geoipv2? ( dev-libs/libmaxminddb:0= )
)
ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_prepare() {
default

# Enable log-format, define log file and db path,
# change path to GeoIP bases in config
sed -i -e '/log-format COMBINED/s/#//' \
-e '/log-file/s/#//' \
-e '/db-path/s|tmp|var/lib/goaccess|' \
-e '/geoip-database/s|local/||' config/goaccess.conf \
|| die "sed failed for goaccess.conf"

eautoreconf
}

src_configure() {
local myeconfargs=(
$(use_enable debug)
$(use_enable geoip geoip "$(usex geoipv2 mmdb legacy)")
$(use_enable unicode utf8)
$(use_with getline)
$(use_with ssl openssl)
)
econf "${myeconfargs[@]}"
}

src_install() {
default

newinitd "${FILESDIR}"/goaccess.initd goaccess
newconfd "${FILESDIR}"/goaccess.confd goaccess
systemd_dounit "${FILESDIR}"/goaccess.service
newtmpfiles "${FILESDIR}"/goaccess.tmpfile goaccess.conf

diropts -o goaccess -g goaccess -m 0700
keepdir /var/lib/goaccess/db /var/log/goaccess
}

pkg_postinst() {
optfeature "update GeoIP databases" net-misc/geoipupdate
tmpfiles_process goaccess.conf
}

0 comments on commit 17da9d0

Please sign in to comment.