Skip to content

Commit

Permalink
media-sound/jack2: version bump to 1.9.12.
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/640984

Package-Manager: Portage-2.3.18, Repoman-2.3.6
  • Loading branch information
karllinden authored and monsieurp committed Dec 20, 2017
1 parent 2da3efa commit 17f973d
Show file tree
Hide file tree
Showing 2 changed files with 92 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/jack2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jack2-1.9.11-RC1.tar.gz 6481650 BLAKE2B b9497efdb72f2e3894a062a3ffdffc3ebf67f5ea7372d993c13581202202e0f0ba7b21563768a984201d8e5eb2854add67fb5c377e2b4ddb23806a38ddddb0f9 SHA512 4fd7d82ab6536b8c6061023858ae5b978903608b149498818971481da75c6e9e0e7e7aef5e1343730c259f4378aebfbf25916b9736e0ad8aa19584a44f894436
DIST jack2-1.9.12.tar.gz 6487135 BLAKE2B 9140b3892d2321576a7329fbef2f23e340be4b9be967ec173edbbc7a43952c9a3712ead05dbe57f958b88c1e29c8a912a937c0bd34e0122ecc600ac9d48f147d SHA512 f0271dfc8f8e2f2489ca52f431ad4fa420665816d6c67a01a76da1d4b5ae91f6dad8c4e3309ec5e0c159c9d312ed56021ab323d74bce828ace26f1b8d477ddfa
91 changes: 91 additions & 0 deletions media-sound/jack2/jack2-1.9.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,91 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"
inherit python-single-r1 waf-utils multilib-minimal

DESCRIPTION="Jackdmp jack implemention for multi-processor machine"
HOMEPAGE="http://jackaudio.org/"

if [[ "${PV}" = "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/jackaudio/${PN}.git"
KEYWORDS=""
else
MY_PV="${PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/jackaudio/jack2/releases/download/v${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86"
fi

LICENSE="GPL-2"
SLOT="2"
IUSE="alsa celt dbus doc opus pam +classic sndfile libsamplerate readline"

REQUIRED_USE="
${PYTHON_REQUIRED_USE}
|| ( classic dbus )"

CDEPEND="media-libs/libsamplerate
media-libs/libsndfile
sys-libs/readline:0=
${PYTHON_DEPS}
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
celt? ( media-libs/celt:0[${MULTILIB_USEDEP}] )
dbus? (
dev-libs/expat[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
)
opus? ( media-libs/opus[custom-modes,${MULTILIB_USEDEP}] )"
DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
RDEPEND="${CDEPEND}
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
pam? ( sys-auth/realtime-base )
!media-sound/jack-audio-connection-kit:0"

DOCS=( ChangeLog README README_NETJACK2 TODO )

src_prepare() {
default
multilib_copy_sources
}

multilib_src_configure() {
local mywafconfargs=(
--htmldir=/usr/share/doc/${PF}/html
$(usex dbus --dbus "")
$(usex classic --classic "")
--alsa=$(usex alsa yes no)
--celt=$(usex celt yes no)
--doxygen=$(multilib_native_usex doc yes no)
--firewire=no
--freebob=no
--iio=no
--opus=$(usex opus yes no)
--portaudio=no
--readline=$(multilib_native_usex readline yes no)
--samplerate=$(multilib_native_usex libsamplerate yes no)
--sndfile=$(multilib_native_usex sndfile yes no)
--winmme=no
)

waf-utils_src_configure ${mywafconfargs[@]}
}

multilib_src_compile() {
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_compile
}

multilib_src_install() {
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_install
}

multilib_src_install_all() {
python_fix_shebang "${ED}"
}

0 comments on commit 17f973d

Please sign in to comment.