Skip to content

Commit

Permalink
dev-ruby/json: add 1.8.6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.1
  • Loading branch information
graaff committed Jun 11, 2017
1 parent 19d4caa commit 180b9ff
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/json/Manifest
Original file line number Diff line number Diff line change
@@ -1,4 +1,5 @@
DIST json-1.8.2.gem 152064 SHA256 256f73d107635f54e3dd84daba65da7b08f9d6a6e6aeb046db6a46b98bd8fb7f SHA512 5c94ec2c5378f7f54cd87a2e265b058e80031d2dd29daf14639c80ba0ac285a527ab7961f5a2cd1e483f455fd8f8c88575950822b7b2d431aa7b2b9c8be819c1 WHIRLPOOL dc17e0c011523434ed29e428a2658ebe58d08df8252e7ee8990882b6d17c19354b3e4ba6985a2a45e4b94932ad265698197ba64ef891f38d3be154da4edde8cb
DIST json-1.8.3.gem 152064 SHA256 8ca2091e26678fb989d66cdb9f0104f1307bc584b429c2fd783d51e4b3f14bdb SHA512 313f6016aca5eba4d4a14a72b60b3e9c5e863a6681eb9e499cacedb63969694be563990af0a44dae52963f07b6e6c7aa7e0876ab1348b214f53d925bdc5e83ea WHIRLPOOL 8c6dc26a578aedcd4bbc1e6ea95f2a72debe6bdaca5a4c2a4e70b81d9947048c6648b62d5546fa572084d37ba99ce199a177b87838be5cc3f11d8d0fa0f62a63
DIST json-1.8.6.gem 144384 SHA256 65af27ca985f70eb0d083aab0f75712c771871222af021ce533bad77bd3bb262 SHA512 8f393da080293965389df4a606e0604c500b4b267897b3c1b9007b7700dde8156f6598c25790e84fa20a7e03c7ae359a0b267c7b84e52dfe2a1ac83cf652ad9b WHIRLPOOL 0d55a8086f54eafa8e2d9e49e71436750b63c4bb7164fe06e5fa298f112f5612c428e3d4377e1ca824577d01eb21a6862b42236a147c85e9faa8a3f623184bf8
DIST json-2.0.4.gem 138752 SHA256 ee1361f37fbd9f06d0de3976cd4320a84119aa41fa7f321eb67244404add3114 SHA512 24105aa06c205b6fe1cd835822d71b81299fdc47a45f48dd8f513f68f7fd12cdb51df476bcaef640916737d22be3156848ee4c9922c4a61aed5ca2d4d0d21c86 WHIRLPOOL 179f95dbfe21fbb8c3a8f97281b93892c167c7e3325d6ff182c0d0e4cc9e3a17bcea118311001756937c1e0e4be09ed7f117ffc824c24df18fc5cc5a31db93ce
DIST json-2.1.0.gem 140800 SHA256 b76fd09b881088c6c64a12721a1528f2f747a1c2ee52fab4c1f60db8af946607 SHA512 bffbe462e952bca321d4325ecb9c5e9f61e51cad13758581ecfaa6a038bac4e30dc7db50bd897086a5592f6fc437d0e0909f91e279aaf4dd71cf127100c3550b WHIRLPOOL 94140475051d90e9b207c6d0224483b5ee0c371a27b7a4aafc612bc2e828cffb350afd4001ba20a3b5ddb124561da960cdb0d757bfbfbba031942d6bbb9cc641
68 changes: 68 additions & 0 deletions dev-ruby/json/json-1.8.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
USE_RUBY="ruby21 ruby22 ruby23 ruby24"

RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_EXTRADOC="CHANGES TODO README.md README-json-jruby.markdown"

RUBY_FAKEGEM_GEMSPEC="json.gemspec"

inherit multilib ruby-fakegem

DESCRIPTION="A JSON implementation as a Ruby extension"
HOMEPAGE="https://github.com/flori/json"
LICENSE="|| ( Ruby GPL-2 )"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
SLOT="0"
IUSE=""

RDEPEND="${RDEPEND}"
DEPEND="${DEPEND}
dev-util/ragel"

ruby_add_bdepend "dev-ruby/rake
doc? ( dev-ruby/rdoc )"

all_ruby_prepare() {
# Avoid building the extension twice!
# And use rdoc instead of sdoc which we don't have packaged
# And don't call git to list files. We're using the pregenerated spec anyway.
sed -i \
-e 's| => :compile||' \
-e 's| => :clean||' \
-e 's|sdoc|rdoc|' \
-e 's|`git ls-files`|""|' \
Rakefile || die "rakefile fix failed"

# Remove hardcoded and broken -O setting.
sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
-e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
}

each_ruby_compile() {
# Since 1.5.0 a Java extension is provided but it does not compile.
if [[ $(basename ${RUBY}) != "jruby" ]]; then
${RUBY} -S rake compile || die "extension compile failed"
fi
}

each_ruby_test() {
JSON=pure \
${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "pure ruby tests failed"

if [[ $(basename ${RUBY}) != "jruby" ]]; then
JSON=ext \
${RUBY} -Iext:lib -S testrb-2 tests/test_*.rb || die "ext ruby tests failed"
fi
}

each_ruby_install() {
each_fakegem_install
if [[ $(basename ${RUBY}) != "jruby" ]]; then
ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
fi
}

0 comments on commit 180b9ff

Please sign in to comment.