Skip to content

Commit

Permalink
dev-python/testify: Bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
patricklauer committed Apr 20, 2016
1 parent 84c8a45 commit 183c57f
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/testify/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST testify-0.5.7.tar.gz 166954 SHA256 153796d3b20b2d8554e52af26a8c891e6f02dfd6cc7be29f9241dad244cff044 SHA512 410ac412306c11bba992b882624fcacdbff00e2865cd986c560d8b50ea8dff0ead8603b18f40414d8dbbe1f3ab9426e0f61170dc450927f6d2282e389800ff21 WHIRLPOOL 2cc958efea71bd475c698cee36e4f1bdb7197c8cb54c38efbf66927d5abc60e769a8995ae7fb4107fab8b74e4b05afcaf16e5c0aec9db3471ddbd771bafa3adf
DIST testify-0.7.2.tar.gz 102858 SHA256 7c209530fbb67344fe8985012056116d7d8eadd6ff126f91c93aa19208fd3ec9 SHA512 4b470aabe1ada88ddaf89145c77dbc5c2d000c8e0fab431535c08b4ff05a04c12f215d4c05d678ba718fdf3295be74fef23041d01d3c05e0b9e2c43c5ab0ed1e WHIRLPOOL 37ff8d7068ba4569215e3df440186ef3149a5fde0e12ec5efefc5b666adf2958b11f4db18995b46536cbf504dadec48f00b5f38e524ae09eb815c8170b8cf669
DIST testify-0.8.0.tar.gz 68996 SHA256 065cb852110547892d6f971b66795e71ee032a4bcc23decb984878b3ba402aaf SHA512 c3a198fbf9d58c817e6eeffbfba282571e87b952f4d473118b13ec9f1451f94309032bea62bdba866eff0932233cc29be4f7731a56db99fae8fa1e2b3f12ecfc WHIRLPOOL c9e8d80ed802b3effd9c63595f1d2557e314f5d358991a6384c1f91c242b15fbb25a931d8f40171f6d4099584743e7eebe3c15ff30f7c8595318a7e490806da2
46 changes: 46 additions & 0 deletions dev-python/testify/testify-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} )

inherit distutils-r1 vcs-snapshot

DESCRIPTION="A more pythonic replacement for the unittest module and nose"
HOMEPAGE="https://github.com/Yelp/testify https://pypi.python.org/pypi/testify/"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
>=dev-python/six-1.7.3[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( ${RDEPEND} )"

python_prepare_all() {
# Correct typo in setup.py
sed -e 's:mock,:mock:' -i setup.py || die

# Correct use of local importing in pertinent test_ files
sed -e s':from .test:from test:' \
-i test/test_runner_test.py || die

distutils-r1_python_prepare_all
}

python_test() {
einfo; einfo "Output reporting exceptions \"ImportError: No module named <module>\""
einfo "are instances of exceptions expected to be raised, similar to xfails by nose"; einfo""
for test in test/test_*_test.py;
do
"${PYTHON}" $test || die "test $test failed under ${EPYTHON}"
done
}

0 comments on commit 183c57f

Please sign in to comment.