Skip to content

Commit

Permalink
games-board/pychess: Version bump.
Browse files Browse the repository at this point in the history
Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
atomsymbol-notifications authored and monsieurp committed Feb 4, 2016
1 parent 685b4a3 commit 1848831
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-board/pychess/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST pychess-0.10.1.tar.gz 1939605 SHA256 8a8ac9fc6a4605d189a9728f55183130b6a304cbf2dc5b2e923297303fe4ae8a SHA512 1000c840954b93bd3720fd3265b6cc0ac33df22373eb965d4ac03d16f7589af3b10bf2ebc28a2ff555b5e4101bffbfe96d52051e6c51a084229a3cc1691f1dd8 WHIRLPOOL 7554456eea487cefe3d8303aacdfa5748345b9682a8c557a2ed53090cc9a5beacc5b2e874db222b75fc03bcaf61dd9d7c3e2df23a13a4db820d4bd34c2f7b66e
DIST pychess-0.12.2.tar.gz 4653011 SHA256 feecabcea35cce0d69100e0c995f0a88d83d1246be512f2348c13e40bff9916e SHA512 d20ff665f47b58dce92ee822c6495fb31b84f19b15e70644cb7caefda837597e075f62cd0aa6bdd36f342d3eaa66174f9fa950800ec77346ef1cccfa7e37c735 WHIRLPOOL 0bca1361412f316f6446579646f1d51d525228a4427137711efdca01c75ed3c769fd83d0c4e942db36daa3dbc22e74dd5410c8a33c06a96458d0755a6fca0131
71 changes: 71 additions & 0 deletions games-board/pychess/pychess-0.12.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"

inherit fdo-mime gnome2-utils distutils-r1 games

DESCRIPTION="A chess client for Gnome"
HOMEPAGE="http://pychess.org/"
SRC_URI="http://pychess.org/download/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gstreamer"

DEPEND="dev-python/librsvg-python
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:2[${PYTHON_USEDEP}]
dev-python/pygtk:2[${PYTHON_USEDEP}]
dev-python/pygtksourceview:2[${PYTHON_USEDEP}]
gstreamer? ( dev-python/gst-python:0.10[${PYTHON_USEDEP}] )
dev-python/gconf-python
x11-themes/gnome-icon-theme"
RDEPEND=${DEPEND}

python_install() {
distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"

# bug 487706
sed -i \
-e "s/@PYTHON@/${EPYTHON}/" \
"${ED%/}/$(python_get_sitedir)"/${PN}/Players/engineNest.py || die
}

python_install_all() {
distutils-r1_python_install_all
dodoc AUTHORS README.md
prepgamesdirs
}

src_prepare() {
distutils-r1_src_prepare
}

src_compile() {
distutils-r1_src_compile
}

src_install() {
distutils-r1_src_install
}

pkg_preinst() {
games_pkg_preinst
gnome2_icon_savelist
}

pkg_postinst() {
games_pkg_postinst
gnome2_icon_cache_update
fdo-mime_desktop_database_update
}

pkg_postrm() {
gnome2_icon_cache_update
fdo-mime_desktop_database_update
}

0 comments on commit 1848831

Please sign in to comment.