Skip to content

Commit

Permalink
dev-python/bibtexparser: New package
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
SoapGentoo committed Apr 10, 2016
1 parent 55853c1 commit 1850fe6
Show file tree
Hide file tree
Showing 4 changed files with 71 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/bibtexparser/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST bibtexparser-0.6.2.tar.gz 50876 SHA256 af6d4802de27cc40d4d65656dd5e269ac05cabb7816be6b520e6ea08c6a626c8 SHA512 43a1c0475bc9e97c201a850e944f082e9eb316ac475cce4128b821008fc5b1597317f28c594f5462daee992b455fb4254fdf76a5baa02ff8e8a0e36f43c52491 WHIRLPOOL 4dcfe250f9319c0910d4076a6ef509b6e914f5c7ee49690dfd91881cbfc208dcbdb59b0f733567f6c3460b53f0785c6ad09ef392a527ca7252e9e109e275d1bf
27 changes: 27 additions & 0 deletions dev-python/bibtexparser/bibtexparser-0.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} )

inherit distutils-r1 python-r1

DESCRIPTION="A BibTeX parser written in python"
HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
SRC_URI="https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"

S="${WORKDIR}/python-${P}"

src_test() {
python_foreach_impl nosetests
}
28 changes: 28 additions & 0 deletions dev-python/bibtexparser/files/python-bibtex-1.2.4-fix_tests.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
--- testsuite.py
+++ testsuite.py
@@ -4,6 +4,7 @@

import sys, os

+ParserError = "ParserError"

def check_recode ():
try:
@@ -65,7 +66,7 @@

valid = result.readline ().strip ()

- if obtained != valid:
+ if eval(obtained) != eval(valid):
sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
filename, line))
sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
@@ -117,7 +118,7 @@

valid = result.readline ().strip ()

- if obtained != valid:
+ if eval(obtained) != eval(valid):
sys.stderr.write ('error: %s: line %d: unexpected result:\n' % (
filename, line))
sys.stderr.write ('error: %s: line %d: obtained %s\n' % (
15 changes: 15 additions & 0 deletions dev-python/bibtexparser/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Python</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo TeX Project</name>
</maintainer>
<upstream>
<remote-id type="github">sciunto-org/python-bibtexparser</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 1850fe6

Please sign in to comment.