Skip to content

Commit

Permalink
app-editors/retext: Version bump to 7.0.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.4, Repoman-2.3.2
  • Loading branch information
mrueg committed Mar 13, 2017
1 parent 4ea737e commit 1882267
Show file tree
Hide file tree
Showing 2 changed files with 54 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-editors/retext/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ReText-4.1.3.tar.gz 129283 SHA256 bb4409982d27ac62cab01b0748fe41d9c66608536
DIST ReText-5.3.1.tar.gz 159669 SHA256 515b1aaa57615453f8933f997753072a5c4691793da2280e70d1b333b53904c6 SHA512 76c6f78c10129e4845de819fa6db3deff5441a25331fd3dadbdfeb766caa453f21214f82e6625c919cc8be2fcfdfada970cae32837bb8904c3702dda19890628 WHIRLPOOL 5c2db75c2b2f23419bc2803849f6b7a69f3540911c6e53f46a46baffd150a9a0db75d0343361963a53bcc1a6da4534eb72d99068a26c13c1551b6188ab81f67a
DIST ReText-6.0.1.tar.gz 184098 SHA256 7c9785cb022d2f0b123b8a808c2419cf1300249d594a72a5ef5a0030de8bb630 SHA512 aca8db5d82fadee7b8d03279e080b33da696339eb674ba1fc2dd4ced7c92b1608d8ed2d181bdbe913601d63755df38ebdfa06f77398e1b52cc922f54fc0fe867 WHIRLPOOL 0590b347e7ca21d7e6e653c74fd53abe2ccb0852e6ab3f53213f8beb38234b0b757bf60ba77f68e485b68332d3b06def94aa4b9aebae369e472a876ce34d9b77
DIST ReText-6.0.2.tar.gz 195339 SHA256 ce28b20673627bd4e17c750d71b73e073776e291b2a1736dd561a1a24aa7f70b SHA512 e8670c03eb2a38b8baeedee4c6e31b52e6e3954f2b1fa0d4249653f77e853aa7fd8ee7a43c98d36194889528dd0da75d4106950385e93d8d2b69139454de1729 WHIRLPOOL a42e4ec9d82e15754bf7aaf4c05a15cbb818a5e4d8b71c7994f0a5dca3f27b5fee56f6a3adfbf49f073e70de11202852b301945884dd8bab63f123128d316557
DIST ReText-7.0.0.tar.gz 203294 SHA256 01eaf11768f27ba1da2572f2dbcf9b6857d5baa3ca1f50d1cacad894a228f032 SHA512 0a2e430659e7d87d50780fecbf5f04f852f144d143ec83b90126ab9e7b8006756cbc8710c9cec192ddad2cba9f7236e684fa207e308c565388ede308da3c1a35 WHIRLPOOL 5f3633c45c6ef7cb44cbd805849a97b81536d762910d44380a6d2836eb7308ed0c449ec282139b0eea07445be051a0cfa4ab7d3b077693a07f4d14beffbfc8ae
53 changes: 53 additions & 0 deletions app-editors/retext/retext-7.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python3_{4,5} )

PLOCALES="ca cs cy da de es et eu fr hu it ja pl pt pt_BR ru sk sr sr@latin uk zh_TW"

inherit distutils-r1 l10n eutils

MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"

DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+spell"

RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/markdown[${PYTHON_USEDEP}]
>=dev-python/markups-2.0[${PYTHON_USEDEP}]
>=dev-python/chardet-2.3[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,webkit,widgets,${PYTHON_USEDEP}]
spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
"

S="${WORKDIR}"/${MY_P}

remove_locale() {
find "${ED}" -name "retext_${1}.qm" -delete || die "Failed to remove locale ${1}."
}

python_test() {
esetup.py test
}

python_install_all() {
distutils-r1_python_install_all

newicon {icons/,}${PN}.png
newicon {icons/,}${PN}.svg

l10n_for_each_disabled_locale_do remove_locale

make_desktop_entry ${PN} "${MY_PN} Editor" ${PN} "Development;Utility;TextEditor"
}

0 comments on commit 1882267

Please sign in to comment.