Skip to content

Commit

Permalink
dev-python/botocore: Bump to 1.18.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 23, 2020
1 parent c0b0e9f commit 1895eb3
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/botocore/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -4,3 +4,4 @@ DIST botocore-1.17.63.tar.gz 6841028 BLAKE2B 89b2d5d520e733deaf3c4b68faa103e4227
DIST botocore-1.18.0.tar.gz 6838497 BLAKE2B efc0930b8ffafdf8d7f24d4f30cbf12e0dd81aa4ae405beee7663271fe8ffe680df91d40f8629b75635fae87ad29f0186e42f11e4bfebc64cc58979edd74e64b SHA512 43b5992d1ffb8d10f32f532c3085825e3775e3da4d6c25c2e300dfcd6e24967bdd318a7be37889a9d7802eb74bd9085b9642cda099b0064cbd9ffd65a56b7de5
DIST botocore-1.18.1.tar.gz 6839699 BLAKE2B 188c5a05345fc7c4d4c05b3a8d9b675b5c2141326caa62f9ae8a5a996f6c7ff4e56c581fd010afbc4c57073d7b6efd22debad3e03456f6ad0453c7f823d6409e SHA512 63a9a7ac93a8774d7a1a511da0464d7b5d0841598c7358e97343406b4d76842ca56a0187ff173e0a29d9da9ee22f94fde66f4b8c3e9c8a3fbcabdaddbe95b752
DIST botocore-1.18.2.tar.gz 6843154 BLAKE2B 77f4cbccd6a686cfbdb2f25fafb9f2210c0e23de72fb40403f905711ec5d073b92cfd003d39406d273feb0bfb90e2ab594f2bb9c1564b5b0879efdf3bcfa47e3 SHA512 f4fec4caf3b4ebca8a593d58827fb4377c2458b7ebccb53ccd830df5423a2021ecebd534d2fe276662f8d8e91078bb5adbf611a52baa29c8ab3526d9c7b975ac
DIST botocore-1.18.3.tar.gz 6846755 BLAKE2B 3f6709cac832dff1ba07c2e8b4c235b5bcdf305c9851eedea2ce5f7847d0be93d7e9cbcb1765add47aaec1d0c1c31cdd2c88542a984af570140ffb7fe30d8388 SHA512 a8831b1549a768cea9d550dc2dc3c1c8afc03e018d2ce246569bed35cb9ce25bcb18689d066dc5b6e6dcc69db93e0b0957b32cb68c101127e01cfe3fbfa9fe08
59 changes: 59 additions & 0 deletions dev-python/botocore/botocore-1.18.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6..9} )

inherit distutils-r1

DESCRIPTION="Low-level, data-driven core of boto 3"
HOMEPAGE="https://github.com/boto/botocore"
LICENSE="Apache-2.0"
SLOT="0"

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/botocore"
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
fi

RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/jmespath[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/urllib3[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/jsonschema[${PYTHON_USEDEP}]
)
"

PATCHES=(
"${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
)

distutils_enable_sphinx docs/source \
'dev-python/guzzle_sphinx_theme'
distutils_enable_tests nose

src_prepare() {
# unpin deps
sed -i -e "s:>=.*':':" setup.py || die
# very unstable
sed -i -e 's:test_stress_test_token_bucket:_&:' \
tests/functional/retries/test_bucket.py || die
distutils-r1_src_prepare
}

python_test() {
# note: suites need to be run separately as one of the unit tests
# seems to be leaking mocks and breaking a few functional tests
nosetests -v tests/unit ||
die "unit tests failed under ${EPYTHON}"
nosetests -v tests/functional ||
die "functional tests failed under ${EPYTHON}"
}

0 comments on commit 1895eb3

Please sign in to comment.