Skip to content

Commit

Permalink
gui-apps/slurp: New package (1.2.0, 9999)
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/684710
Package-Manager: Portage-2.3.70, Repoman-2.3.16
Signed-off-by: Bernardo Meurer <[email protected]>
Closes: gentoo#12614
Signed-off-by: Aaron Bauman <[email protected]>
  • Loading branch information
lovesegfault authored and FuzzyGophers committed Aug 9, 2019
1 parent 264467e commit 18a65ca
Show file tree
Hide file tree
Showing 4 changed files with 108 additions and 0 deletions.
1 change: 1 addition & 0 deletions gui-apps/slurp/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST slurp-1.2.0.tar.gz 15317 BLAKE2B 92de74abb54b2d53334e0f0c5d08b0b50e9c4583eb192226e38fcefa07cce2265f808ce81c04170e65d3c1209fa263352e3d70cc0a7cf745ed5e18d57c4d3af6 SHA512 443cd497049a5128e80a48c7b2afcc555a8d58a5eacc2dc6207058a9a399bc9e9804c7bca8b010af63f8be99000c05245720bd3e8cca248a74d5aa63a7faf4f9
23 changes: 23 additions & 0 deletions gui-apps/slurp/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Bernardo Meurer</name>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Proxy Maintainers Project</name>
</maintainer>
<longdescription lang="en">
Select a region in a Wayland compositor and print it to the standard output.
</longdescription>
<use>
<flag name="man">Generate and install man pages.</flag>
</use>
<upstream>
<remote-id type="github">emersion/slurp</remote-id>
<bugs-to>https://github.com/emersion/slurp/issues</bugs-to>
<changelog>https://github.com/emersion/slurp/releases</changelog>
</upstream>
</pkgmetadata>
43 changes: 43 additions & 0 deletions gui-apps/slurp/slurp-1.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
HOMEPAGE="https://github.com/emersion/slurp"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+man"

DEPEND="
>=dev-libs/wayland-protocols-1.14
dev-libs/wayland
x11-libs/cairo
"
RDEPEND="
${DEPEND}
"
if [[ ${PV} == 9999 ]]; then
BDEPEND+="man? ( ~app-text/scdoc-9999 )"
else
BDEPEND+="man? ( app-text/scdoc )"
fi

src_configure() {
local emesonargs=(
$(meson_feature man man-pages)
"-Dwerror=false"
)
meson_src_configure
}
41 changes: 41 additions & 0 deletions gui-apps/slurp/slurp-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit meson

DESCRIPTION="Select a region in a Wayland compositor and print it to the standard output."
HOMEPAGE="https://github.com/emersion/slurp"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
else
SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

LICENSE="MIT"
SLOT="0"
IUSE="+man"

DEPEND="
>=dev-libs/wayland-protocols-1.14
dev-libs/wayland
x11-libs/cairo
"
RDEPEND="
${DEPEND}
"
BDEPEND="
man? ( app-text/scdoc )
"

src_configure() {
local emesonargs=(
$(meson_feature man man-pages)
"-Dwerror=false"
)
meson_src_configure
}

0 comments on commit 18a65ca

Please sign in to comment.