Skip to content

Commit

Permalink
dev-lang/fennel: new package; add version 0.9.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Maciej Barć <[email protected]>
  • Loading branch information
xgqt committed Nov 28, 2021
1 parent 8e476a9 commit 190d6e9
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/fennel/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST fennel-0.9.1.tar.gz 203441 BLAKE2B 74f461b3e7a24cdae0c8dde590814cb9753a12ab62e797746cc8753d178007a09084037e443d8309fa11ff309a5c6bf6c2e369942ef357aa0402883cef278542 SHA512 87e7ffbef0b49499a93255f50e77f53b9be4faa6d4609d8d65e3a64470bbf07b49a55e7dd547fda4b0e5fe0f4f1e6ece18282cc89955a57ed0a50be8dc01261c
32 changes: 32 additions & 0 deletions dev-lang/fennel/fennel-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

LUA_COMPAT=( lua5-{1,3,4} luajit )

inherit lua-single

DESCRIPTION="Lisp-like language that compiles to Lua"
HOMEPAGE="https://fennel-lang.org/"

if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.sr.ht/~technomancy/fennel"
else
SRC_URI="https://git.sr.ht/~technomancy/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi

LICENSE="MIT"
SLOT="0"
REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="${LUA_DEPS}"
DEPEND="${RDEPEND}"

src_install() {
emake LUA_LIB_DIR="${ED}/$(lua_get_lmod_dir)" PREFIX="${ED}/usr" install
doman ${PN}.1
dodoc *.md
}
29 changes: 29 additions & 0 deletions dev-lang/fennel/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">

<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Maciej Barć</name>
</maintainer>
<longdescription lang="en">
Fennel is a lisp that compiles to Lua. It aims to be easy to use,
expressive, and has almost zero overhead compared to handwritten Lua.

- Full Lua compatibility - You can use any function or library from Lua.
- Zero overhead - Compiled code should be just as or more efficient
than hand-written Lua.
- Compile-time macros - Ship compiled code with no runtime dependency
on Fennel.
- Embeddable - Fennel is a one-file library as well as an executable.
Embed it in other programs to support runtime extensibility and
interactive development.

At https://fennel-lang.org there's a live in-browser REPL you can use
without installing anything.
</longdescription>
<upstream>
<bugs-to>https://github.com/bakpakin/Fennel/issues</bugs-to>
<remote-id type="github">bakpakin/Fennel</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 190d6e9

Please sign in to comment.