forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-i18n/kcm-fcitx: Version bump (0.5.4).
- Loading branch information
Showing
2 changed files
with
61 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST kcm-fcitx-0.4.3.tar.xz 56864 SHA256 b7e9ad4569c0940f9654d58de1f13281fcbcab56febbd346951edcfa0a86e208 SHA512 d311699a5d99f75d353899b7fba0a950491ee8b891724b855033449900ec4b3db9408bb1b80e60ceb0dbb0ce91072162062261a497f83a2a683214b71c3f4713 WHIRLPOOL 04aec049436a120362d02ba900a0d8639feb359b4cc6b99a871c7ffa8d9660270c321828b8660c718890a7f0ea308ea584711ed712762aab712fe8d7e72a205a | ||
DIST kcm-fcitx-0.5.3.tar.xz 57488 SHA256 f2de5fa4e31a96fea059e4d390c6f1d6fdc98af572c19a0e84cf6181da7c2935 SHA512 19d172cbf1d2a13f289b64b67488ddc5ba83a9d26503438045271c85df3775715614951652dc6f8da52a3b9d692d6e2138a760fc51d1e7f0f8bb0bd467265496 WHIRLPOOL 7be5cfb389bfcf5f451b5619c0818afeaa7b88199375b2f5d85bdcc21b1259008a3653f1cd26e33689a9f18130bc53269dceb20fca5b64aaa8f619e06f2d413e | ||
DIST kcm-fcitx-0.5.4.tar.xz 59744 SHA256 ebf81446bd7f9478b421c4ab8b8e050d13a15327a3b6cde93cf62ed09a697402 SHA512 349fe50303e027f44b53d954c088e441450aad07dac3a1162a5dcf9c445ca9d04bd3c36475c17dab91ed2df9c3c71031d7582e39b85ad0465a816f7fc24ac0bd WHIRLPOOL e7d9bcad0e1fbe1cb576f69a82e26b4e910e930003b51940cafc5ddcef65eaab0b4c608c8ba878b12a101aad811e74cf9546be129f833b3c7cd33c3597b00fbd |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,60 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI="6" | ||
|
||
inherit cmake-utils | ||
|
||
if [[ "${PV}" =~ (^|\.)9999$ ]]; then | ||
inherit git-r3 | ||
|
||
EGIT_REPO_URI="https://github.com/fcitx/kcm-fcitx" | ||
fi | ||
|
||
DESCRIPTION="KDE configuration module for Fcitx" | ||
HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/kcm-fcitx" | ||
if [[ "${PV}" =~ (^|\.)9999$ ]]; then | ||
SRC_URI="" | ||
else | ||
SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz" | ||
fi | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="5" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=app-i18n/fcitx-4.2.8 | ||
>=app-i18n/fcitx-qt5-1.1 | ||
dev-qt/qtcore:5 | ||
dev-qt/qtdbus:5 | ||
dev-qt/qtgui:5 | ||
dev-qt/qtwidgets:5 | ||
kde-frameworks/kcmutils:5 | ||
kde-frameworks/kcoreaddons:5 | ||
kde-frameworks/ki18n:5 | ||
kde-frameworks/kio:5 | ||
kde-frameworks/kitemviews:5 | ||
kde-frameworks/knewstuff:5 | ||
kde-frameworks/kwidgetsaddons:5 | ||
virtual/libintl | ||
!${CATEGORY}/${PN}:4[-minimal(-)]" | ||
DEPEND="${RDEPEND} | ||
kde-frameworks/extra-cmake-modules:5 | ||
sys-devel/gettext | ||
virtual/pkgconfig" | ||
|
||
src_prepare() { | ||
# x11-libs/libxkbfile only used by kbd-layout-viewer not ported to Qt 5 / KDE 5. | ||
sed -e "/find_package(XkbFile REQUIRED)/d" -i CMakeLists.txt | ||
|
||
cmake-utils_src_prepare | ||
} | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DKDE_INSTALL_USE_QT_SYS_PATHS=yes | ||
) | ||
|
||
cmake-utils_src_configure | ||
} |