Skip to content

Commit

Permalink
dev-ruby/minitar: add 0.12.1
Browse files Browse the repository at this point in the history
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Sep 8, 2024
1 parent d8cc966 commit 1976a8a
Show file tree
Hide file tree
Showing 2 changed files with 40 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/minitar/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST minitar-0.12.1.tar.gz 33096 BLAKE2B 2277a21f7f29c52b54c26c19960970faa4a892fdb2eb3cf8825b1e668de16b2b1afe2d61dc092e56e65064f9df00945bb408c7b38499e057efc3a2c4cf9b6656 SHA512 7bd79f4a98add766e4391e1db43745c746e138ac7857bb771d8f00b4051025afcdf76af02085f601b5ad92c6c43205bd5f51a80289db14ba72f050faf5d0168e
DIST minitar-0.9.tar.gz 33873 BLAKE2B 6d285c181510c96f173d850a9411da8a214459da14895e2d186ce712387d390c8ac95e27e4e768005540fdfb7463f32206085a72faf4de6b24c31cb732234260 SHA512 e3aaf0e664a985704cf9dccb72250ea2a7ebb2db9b6120590fb8d5525fe2717e0a90b3020f461ae0c4dfb19dc8728b4eeb6ba2e24ab75d12fbd7f5d98b269c79
39 changes: 39 additions & 0 deletions dev-ruby/minitar/minitar-0.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
USE_RUBY="ruby31 ruby32 ruby33"

RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_RECIPE_DOC="none"

RUBY_FAKEGEM_EXTRADOC="History.md README.rdoc"

RUBY_FAKEGEM_GEMSPEC="minitar.gemspec"

inherit ruby-fakegem

DESCRIPTION="Provides POSIX tarchive management from Ruby programs"
HOMEPAGE="https://github.com/halostatue/minitar"
SRC_URI="https://github.com/halostatue/minitar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
RUBY_S="minitar-${PV}"

LICENSE="|| ( BSD-2 Ruby-BSD )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="test"

ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.3:5 )"

all_ruby_prepare() {
sed -e '/focus/ s:^:#:' \
-i test/minitest_helper.rb || die

# Fix spec broken not casting write input to strings
sed -e '/def write/adat = dat.to_s' \
-i test/test_tar_writer.rb || die
}

each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}

0 comments on commit 1976a8a

Please sign in to comment.