forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-python/clang-python: Add 20.0.0_pre20240808 snapshot
Signed-off-by: Michał Górny <[email protected]>
- Loading branch information
Showing
2 changed files
with
54 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
53 changes: 53 additions & 0 deletions
53
dev-python/clang-python/clang-python-20.0.0_pre20240808.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,53 @@ | ||
# Copyright 1999-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
PYTHON_COMPAT=( python3_{10..13} ) | ||
inherit llvm.org python-r1 | ||
|
||
DESCRIPTION="Python bindings for sys-devel/clang" | ||
HOMEPAGE="https://llvm.org/" | ||
|
||
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA" | ||
SLOT="0" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
REQUIRED_USE="${PYTHON_REQUIRED_USE}" | ||
|
||
# The module is opening libclang.so directly, and doing some blasphemy | ||
# on top of it. | ||
DEPEND=" | ||
>=sys-devel/clang-${PV}:* | ||
!sys-devel/llvm:0[clang(-),python(-)] | ||
!sys-devel/clang:0[python(-)] | ||
" | ||
RDEPEND=" | ||
${DEPEND} | ||
${PYTHON_DEPS} | ||
" | ||
BDEPEND=" | ||
${PYTHON_DEPS} | ||
test? ( | ||
sys-devel/clang:${LLVM_MAJOR} | ||
) | ||
" | ||
|
||
LLVM_COMPONENTS=( clang/bindings/python ) | ||
llvm.org_set_globals | ||
|
||
python_test() { | ||
# tests rely on results from a specific clang version, so override | ||
# the search path | ||
local -x CLANG_LIBRARY_PATH=${BROOT}/usr/lib/llvm/${LLVM_MAJOR}/$(get_libdir) | ||
local -x CLANG_NO_DEFAULT_CONFIG=1 | ||
"${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}" | ||
} | ||
|
||
src_test() { | ||
python_foreach_impl python_test | ||
} | ||
|
||
src_install() { | ||
python_foreach_impl python_domodule clang | ||
} |