Skip to content

Commit

Permalink
dev-ml/jbuilder: convert to opam.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
aballier committed Aug 2, 2017

Unverified

This user has not yet uploaded their public signing key.
1 parent 880590a commit 19d34c8
Showing 1 changed file with 3 additions and 11 deletions.
14 changes: 3 additions & 11 deletions dev-ml/jbuilder/jbuilder-1.0_beta11.ebuild
Original file line number Diff line number Diff line change
@@ -3,6 +3,8 @@

EAPI=5

inherit opam

MY_PV="${PV/_/+}"
MY_P="${PN}-${PV/_/-}"

@@ -15,10 +17,9 @@ SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
IUSE="test"

DEPEND="dev-lang/ocaml:="
DEPEND=""
RDEPEND="${DEPEND}"
DEPEND="${DEPEND}
dev-ml/opam
test? ( dev-ml/menhir )
"
OPAMSWITCH="system"
@@ -30,12 +31,3 @@ src_prepare() {
# Disable Werror like behavior, doesnt build with ocaml 4.05 otherwise
sed -i -e 's/--dev//' Makefile || die
}

src_install() {
opam-installer -i \
--prefix="${ED}/usr" \
--libdir="${D}/$(ocamlc -where)" \
--docdir="${ED}/usr/share/doc/${PF}" \
--mandir="${ED}/usr/share/man" \
${PN}.install || die
}

0 comments on commit 19d34c8

Please sign in to comment.