Skip to content

Commit

Permalink
gnome-base/nautilus: bump to 3.22.3, fixing build with USE=-tracker
Browse files Browse the repository at this point in the history
Include the fact that USE=tracker is needed for batch renaming in metadata.xml.
Make exempi depend specify a SLOT as 3.20 was made to post-3.22 bump.

Gentoo-bug: 604720
Package-Manager: Portage-2.3.4, Repoman-2.3.1
  • Loading branch information
leio committed Mar 16, 2017
1 parent d6cdf9b commit 1a1ed7a
Show file tree
Hide file tree
Showing 3 changed files with 113 additions and 0 deletions.
1 change: 1 addition & 0 deletions gnome-base/nautilus/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST nautilus-3.20.4.tar.xz 3453376 SHA256 b15f4778950752e5d5748f198d69106be3425cdc70574be75c25f8f931a2766c SHA512 01bee5c70067c508ca918948afe0b400680eb68518ae69803e2971a215b0eaf54c9251566c6c44835a1c0b9b20248450539a47936c6aba5c9accc9ef3cbe8a8e WHIRLPOOL bf9a3549cb16c8860a470aac07b91cee349adf7ac820847afe093db160fd2f9a4c9f2c6cf7625c7f19415a6957547353662edd33358ddf0b1a86f33169812314
DIST nautilus-3.22.2.tar.xz 5120196 SHA256 ce1c9e97173b51750521971a26943593b397a08a2736b340ef5b130095ee65b3 SHA512 2a11801ded930a0a8a699e385063954ff1e579c0c78ffc209c5da9c8f06fde91cccf01e6d6b97e4c1faee96d1fe3415197e8df14cb1cd876de42240d9f0eedae WHIRLPOOL d7cb14e0801e6aeefb220071bffbd7469cb41359e7a8f54a7f1ac165a86d4052ff5de8850c93692a7b63313c655074ede4885ae787196722f9df2c4038cb4f2b
DIST nautilus-3.22.3.tar.xz 5104800 SHA256 64c232f743a2bae3fce3c76d5aa65e378d11bb431fefde9013162069abff4e22 SHA512 abad02d2b36230348cec04bcc2650cc352e232008c4e628096880a93b647a0da86b43b9df6cbd621334e7292e2d00f68010783858dbfa38061ab7eafd3c4c912 WHIRLPOOL 7dde08228204b2817942071b0a5a1d31ba2d699b96ef821b4cdff301e8d26fd92a36f82b74e7acfeda4018cfa3dc082b0aac66360b0dc940706fd877755e2a48
1 change: 1 addition & 0 deletions gnome-base/nautilus/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,5 +13,6 @@
<flag name="sendto">Enable the nautilus-sendto extension to send files to
various locations/devices</flag>
<flag name="tracker">Add support for <pkg>app-misc/tracker</pkg> search</flag>
<flag restrict="&gt;=gnome-base/nautilus-3.22" name="tracker">Add support for <pkg>app-misc/tracker</pkg> search and batch rename</flag>
</use>
</pkgmetadata>
111 changes: 111 additions & 0 deletions gnome-base/nautilus/nautilus-3.22.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,111 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GNOME2_LA_PUNT="yes" # Needed with USE 'sendto'

inherit gnome2 readme.gentoo-r1 virtualx

DESCRIPTION="A file manager for the GNOME desktop"
HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"

LICENSE="GPL-2+ LGPL-2+ FDL-1.1"
SLOT="0"
IUSE="exif gnome +introspection packagekit +previewer selinux sendto tracker xmp"

KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"

# FIXME: tests fails under Xvfb, but pass when building manually
# "FAIL: check failed in nautilus-file.c, line 8307"
# need org.gnome.SessionManager service (aka gnome-session) but cannot find it
RESTRICT="test"

# Require {glib,gdbus-codegen}-2.30.0 due to GDBus API changes between 2.29.92
# and 2.30.0
COMMON_DEPEND="
>=app-arch/gnome-autoar-0.1
>=dev-libs/glib-2.49.1:2[dbus]
>=x11-libs/pango-1.28.3
>=x11-libs/gtk+-3.21.6:3[introspection?]
>=dev-libs/libxml2-2.7.8:2
>=gnome-base/gnome-desktop-3:3=
gnome-base/dconf
>=gnome-base/gsettings-desktop-schemas-3.8.0
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
exif? ( >=media-libs/libexif-0.6.20 )
introspection? ( >=dev-libs/gobject-introspection-0.6.4:= )
selinux? ( >=sys-libs/libselinux-2 )
tracker? ( >=app-misc/tracker-0.16:= )
xmp? ( >=media-libs/exempi-2.1.0:2 )
"
DEPEND="${COMMON_DEPEND}
>=dev-lang/perl-5
>=dev-util/gdbus-codegen-2.33
>=dev-util/gtk-doc-am-1.10
>=sys-devel/gettext-0.19.7
virtual/pkgconfig
x11-proto/xproto
"
RDEPEND="${COMMON_DEPEND}
packagekit? ( app-admin/packagekit-base )
sendto? ( !<gnome-extra/nautilus-sendto-3.0.1 )
"

# For eautoreconf
# gnome-base/gnome-common
# dev-util/gtk-doc-am"

PDEPEND="
gnome? ( x11-themes/adwaita-icon-theme )
tracker? ( >=gnome-extra/nautilus-tracker-tags-0.12 )
previewer? ( >=gnome-extra/sushi-0.1.9 )
sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
>=gnome-base/gvfs-1.14[gtk]
"
# Need gvfs[gtk] for recent:/// support

src_prepare() {
if use previewer; then
DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
To activate the previewer, select a file and press space; to
close the previewer, press space again."
fi
gnome2_src_prepare
}

src_configure() {
gnome2_src_configure \
--enable-desktop \
--disable-profiling \
--disable-update-mimedb \
$(use_enable exif libexif) \
$(use_enable introspection) \
$(use_enable packagekit) \
$(use_enable sendto nst-extension) \
$(use_enable selinux) \
$(use_enable tracker) \
$(use_enable xmp)
}

src_test() {
virtx emake check
}

src_install() {
use previewer && readme.gentoo_create_doc
gnome2_src_install
}

pkg_postinst() {
gnome2_pkg_postinst

if use previewer; then
readme.gentoo_print_elog
else
elog "To preview media files, emerge nautilus with USE=previewer"
fi
}

0 comments on commit 1a1ed7a

Please sign in to comment.