Skip to content

Commit

Permalink
app-arch/alien: add support for more tar extensions.
Browse files Browse the repository at this point in the history
Courtesy of Austin English <[email protected]>.

I've also slipped in a EAPI 6 update whilst at it.

Closes: https://bugs.gentoo.org/629524
Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
monsieurp committed May 23, 2018
1 parent 347eb06 commit 1a7acfd
Show file tree
Hide file tree
Showing 2 changed files with 59 additions and 0 deletions.
34 changes: 34 additions & 0 deletions app-arch/alien/alien-8.95-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit perl-module

DESCRIPTION="Converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
HOMEPAGE="http://kitenet.net/programs/alien"
SRC_URI="mirror://debian/pool/main/a/${PN}/${PN}_${PV}.tar.xz -> ${P}.tar.xz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
IUSE="+bzip2"

RDEPEND="
app-arch/rpm
app-arch/dpkg
dev-util/debhelper
>=app-arch/tar-1.14.91
bzip2? (
app-arch/bzip2
)"

DEPEND="${RDEPEND}"

PATCHES=( "${FILESDIR}/${P}-tar-extensions.patch" )

src_prepare() {
default
sed -e s%'$(VARPREFIX)'%${D}% -e s%'$(PREFIX)'%${D}/usr%g \
-i "${S}"/Makefile.PL || die "sed failed"
}
25 changes: 25 additions & 0 deletions app-arch/alien/files/alien-8.95-tar-extensions.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
From 01aabf053ea28308df87272cca79e645a9268fd7 Mon Sep 17 00:00:00 2001
From: Austin English <[email protected]>
Date: Fri, 1 Sep 2017 02:20:37 -0500
Subject: [PATCH] add more tar extensions

Signed-off-by: Austin English <[email protected]>
---
Alien/Package/Tgz.pm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Alien/Package/Tgz.pm b/Alien/Package/Tgz.pm
index 7ab6e8b..65a3d2d 100644
--- a/Alien/Package/Tgz.pm
+++ b/Alien/Package/Tgz.pm
@@ -11,7 +11,7 @@ use strict;
use base qw(Alien::Package);
use Cwd qw(abs_path);

-my $tarext=qr/\.(?:tgz|tar(?:\.(?:gz|Z|z|bz|bz2))?|taz)$/;
+my $tarext=qr/\.(?:taz|tar(?:\.(?:bz|bz2|gz|Z|z|))?|tb2|tbz|tbz2|tZ|xpak)$/;

=head1 DESCRIPTION

--
2.14.0

0 comments on commit 1a7acfd

Please sign in to comment.