Skip to content

Commit

Permalink
dev-python/enzyme: Bump to 0.5.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Jun 24, 2024
1 parent 05c8836 commit 1a8134b
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-python/enzyme/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST enzyme-0.4.1.tar.gz 47953 BLAKE2B e81faf1c0b3316511706c2a31f56cdc2230fbce468017134692f1892439c4aa043c5537b78fd267b83d84a1811e2c015aa37d724813da5864f14ae04a9fd961a SHA512 62a85c076a7eb320249a507dcc9dd26572e3a9b9643e0a960ed114a80c75213e6e5028a726fbcdd0c2c46c53af980a69828a54a66af9a17af3210273376395b3
DIST enzyme-0.5.0.tar.gz 27623 BLAKE2B f472883d44eb5e30250a3d5742b7610cebbdeee363c94f543107c9b1661558e9df9e17b14f670fe98d36c30a6179af9470b550ad696679ca7b52c17f8c832020 SHA512 fa8eadbb9cc5bcc18362496342b8d3f42398ed77ed42a51bf186665a4664050f6ef0dcfbbe7e4d5cfe2f0e1c5f19981a87780b3f8c1e2eeeaa47eaf7c0b55d5d
DIST matroska_test_w1_1.zip 184550509 BLAKE2B f111725aa08267661942072c2d4ac019d3d322c4e933aad10afb3aa6f69bb3469114c4400d161e53d8a7618b818b22465177460003804a7ac3e69fa4f4db000d SHA512 f170a8e83dab15228f992b3692330163da2402b8e436c7fa195ac1ecc06cf1eaf1a48d8c99a85c031122c158c2d4006023aae75d5b7805385ba25a6d601cb78f
DIST test1.mkv.yml 156640 BLAKE2B 9afc0d99de3a8ca6f1df3b9302f6e57ab8003bd49e82e9b49aac60b04a7ae5197cbc34f20c806e95dbdd91311e1103075992549d2b8ef49479870a8ecd9dd1be SHA512 1b17e98ddf36ae5df5ee7cca331c960683770e7af7451950483541fb720416b0eccd77e2b6a9a83081996020c1db77d19cc849d30dcdb8623c75a92048ef98db
50 changes: 50 additions & 0 deletions dev-python/enzyme/enzyme-0.5.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE='xml(+)'

inherit distutils-r1 pypi

DESCRIPTION="Python video metadata parser"
HOMEPAGE="
https://github.com/Diaoul/enzyme/
https://pypi.org/project/enzyme/
"
SRC_URI+="
test? (
https://downloads.sourceforge.net/matroska/test_files/matroska_test_w1_1.zip
https://github.com/Diaoul/enzyme/raw/0.5.0/tests/parsers/ebml/test1.mkv.yml
)
"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"

BDEPEND="
test? (
app-arch/unzip
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

src_unpack() {
unpack "${P}.tar.gz"

if use test; then
mkdir -p "${P}"/tests/{data,parsers/ebml} || die
if [[ -f ${P}/tests/parsers/ebml/test1.mkv.yml ]]; then
die "Missing test data added, update"
fi
cp "${DISTDIR}"/test1.mkv.yml "${P}"/tests/parsers/ebml/ || die
cd "${P}"/tests/data || die
unpack matroska_test_w1_1.zip
fi
}

0 comments on commit 1a8134b

Please sign in to comment.