Skip to content

Commit

Permalink
dev-ros/ament_cmake_python: bump to 0.9.6
Browse files Browse the repository at this point in the history
Use cmake.eclass
Add python check deps

Closes: https://bugs.gentoo.org/708572
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Alexis Ballier <[email protected]>
  • Loading branch information
aballier committed Jul 23, 2020
1 parent 50340b8 commit 1ac3ce8
Show file tree
Hide file tree
Showing 3 changed files with 56 additions and 3 deletions.
1 change: 1 addition & 0 deletions dev-ros/ament_cmake_python/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
DIST ament_cmake-0.9.6.tar.gz 60800 BLAKE2B 71c4e71c50b7715bb8f1b5b737ce23e30f79459a14a5866801bcb810b8fe82d807b6a4eae11de427f52c618e14ef22b7693905f1a0200cc38f0ffab1d70e80cd SHA512 c923260bbd0142ea57bf3e868e94e76020939e8ec49cbf23f14221d0048f21efed00dcdae9978e00f246725ba216c151f5d53b1cd94297b8731f53dc0e45b554
47 changes: 47 additions & 0 deletions dev-ros/ament_cmake_python/ament_cmake_python-0.9.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit cmake python-any-r1

ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
fi

DESCRIPTION="The ability to use Python in the ament buildsystem"
HOMEPAGE="https://github.com/ament/ament_cmake"

LICENSE="Apache-2.0"
SLOT="0"
if [ "${PV#9999}" != "${PV}" ] ; then
KEYWORDS=""
else
KEYWORDS="~amd64"
fi
IUSE=""

RDEPEND="
dev-ros/ament_cmake_core
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
BDEPEND="
$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
PATCHES=( "${FILESDIR}/destdir.patch" )

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}
11 changes: 8 additions & 3 deletions dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 2019 Gentoo Authors
# Copyright 2019-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python{3_6,3_7} )
PYTHON_COMPAT=( python{3_6,3_7,3_8} )

inherit cmake-utils python-any-r1
inherit cmake python-any-r1

ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
Expand Down Expand Up @@ -40,3 +40,8 @@ BDEPEND="
${PYTHON_DEPS}
"
PATCHES=( "${FILESDIR}/destdir.patch" )

python_check_deps() {
has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}

0 comments on commit 1ac3ce8

Please sign in to comment.