Skip to content

Commit

Permalink
dev-php/xdebug-client: bump to v2.9.4
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Mar 30, 2020
1 parent 36cfc7c commit 1b4cfca
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/xdebug-client/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST xdebug-2.6.1.tgz 283961 BLAKE2B 4478d591591102a9efa248820831e4d43d89eb9b80379c92fe85c888377a31d855ac4ea98c13ad87da68f7e7f659483cfa36fd4651f245d5603fcada2e2fcf73 SHA512 31f26e592b3888d7cc74c6a7c51e0cc1151cf8a32100dda78098fb5b3e307cf8d0445b97247986c75b303a787f89b3937bc042dc52f19ca995753a6843bbd80b
DIST xdebug-2.9.2.tar.gz 432926 BLAKE2B 3d524e5a1aec0621389970e80cdc23dfd40a17113ad09294de65290531cac1b33cbc248be341e0c29d9ebb825be25dd6d6b65b9ebcca0c2c3ca43784d2bf9d50 SHA512 ef1780f34572ea47de7e107b5120a0ec640e0ce4ec2a1c98c128c4f69ec9916879d82b11d2eb94d9630ed27b2d20afec7ccda9f79040d47dbaba9e1933331d03
DIST xdebug-2.9.3.tar.gz 434509 BLAKE2B dd6a42518e9100db32a4858f131fc5cd8f6ed715bbf16a8d20fbba40b7503a897dd6d010af81d0001301b999a64b5d67b193c72a456e396b54ddd61823556d57 SHA512 ec77a036e622a867d4ef46aa844d4d3a2b9ce04c8ce64300451f50539c9889dd10cec96b18292268540e2aee0260caeffbd9fa03abd24891b4c9fe68d02598d5
DIST xdebug-2.9.4.tar.gz 434622 BLAKE2B bd0d0c6a46867ffba88693f142346d11b5abfab3254c549b74ff9169536c42903b1fb1cb94c3344060590b63e287878ea05c6ef7ad8343234bada3857e0dbe75 SHA512 cf19fb9fd12c32e04c18f296694d0667dfe6e14617da932804d17526c88ab19dd2307ad43d036a8c0cb1f871a964523473879da8815f346faf83ec3b9e3952e3
40 changes: 40 additions & 0 deletions dev-php/xdebug-client/xdebug-client-2.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

MY_PN="xdebug"
MY_PV="${PV/_/}"
MY_PV="${MY_PV/rc/RC}"

inherit autotools

DESCRIPTION="Xdebug client for the Common Debugger Protocol (DBGP)"
HOMEPAGE="https://xdebug.org/"
# Using tarball from GitHub for tests
#SRC_URI="http://pecl.php.net/get/xdebug-${MY_PV}.tgz"
SRC_URI="https://github.com/xdebug/xdebug/archive/${MY_PV}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
LICENSE="Xdebug"
SLOT="0"
IUSE="libedit"

S="${WORKDIR}/${MY_PN}-${MY_PV}/debugclient"

DEPEND="libedit? ( dev-libs/libedit ) net-libs/libnsl:0="
RDEPEND="${DEPEND}"

src_prepare() {
default

eautoreconf
}

src_configure() {
econf $(use_with libedit)
}

src_install() {
newbin debugclient xdebug
}

0 comments on commit 1b4cfca

Please sign in to comment.