Skip to content

Commit

Permalink
net-analyzer/fail2ban: Version bump (bug #576812).
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.27
  • Loading branch information
Jeroen Roovers committed Mar 9, 2016
1 parent 6716687 commit 1bbd415
Show file tree
Hide file tree
Showing 2 changed files with 103 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-analyzer/fail2ban/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST fail2ban-0.9.2.tar.gz 314919 SHA256 3e002f916e71128d4d7a97354b3e9b3bc20add878c9aa29c4034744de6156893 SHA512 c0fe3b126bcab34599661eaba9a84a8748e1450de57bc43cf91434d478463af1f60dc2bd2b50f7419fb1020ed63d398ca8493bd156cf1905767dbb8f79d0fda1 WHIRLPOOL 11264467e1465ad8697e174dcc751a63c0f550a01d381981f0b8bbc6f6c8f1b2ab13c2df205b08662e0e4bf983a139211932942795693c2c2cca71da9ddb833d
DIST fail2ban-0.9.3.tar.gz 321960 SHA256 146811530b7acf706db6d28068ee60806f6e0c80da14d89b732955a696728c46 SHA512 c8f45f776677a1e2e222feb4e33499a59c0c1c108365b759daf417870e2cc717a8b26073869eb3846a24928d8a2d33225761a19965b804bb7fee750e86cef6c8 WHIRLPOOL d01a25a9ac422e538e15db5f4f6c5015ee5c429c8fa6adf35accb80ce56f8e703e5104860ca7b205b927697b20a9a1109852dc6059b6ce208c432e0661a78edb
DIST fail2ban-0.9.4.tar.gz 335521 SHA256 9a4a6402f8e6bda15ef8b5a848ce8d91d80735356b52dfac0d7612cdd2fbcaf3 SHA512 fee7368adf30c9b5a47309c0c519de9fb0113a49b5e69d0f9396b5fb3dc9a3c6a5a51fef155fcf7debd86eb839441d1199c992fa8211da83a81f7c182c4a2125 WHIRLPOOL 5d44f39204eb3717f00102c686b5b3873555b82dd3bcae0bfbbb96f54e15d0d020655c3b3efe51536a5746489d133e2dc5bf3d3b7081c6619ba2ab715abe4ba2
102 changes: 102 additions & 0 deletions net-analyzer/fail2ban/fail2ban-0.9.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
DISTUTILS_SINGLE_IMPL=1

inherit distutils-r1 eutils systemd vcs-snapshot

DESCRIPTION="scans log files and bans IPs that show malicious signs"
HOMEPAGE="http://www.fail2ban.org/"
SRC_URI="https://github.com/${PN}/${PN}/tarball/${PV} -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="selinux systemd"

RDEPEND="
kernel_linux? ( net-firewall/iptables )
net-misc/whois
virtual/logger
virtual/mta
selinux? ( sec-policy/selinux-fail2ban )
systemd? ( $(python_gen_cond_dep '|| (
dev-python/python-systemd[${PYTHON_USEDEP}]
sys-apps/systemd[python(-),${PYTHON_USEDEP}]
)' 'python*' ) )
"

REQUIRED_USE="systemd? ( !python_single_target_pypy )"

DOCS=( ChangeLog DEVELOP README.md THANKS TODO doc/run-rootless.txt )

src_prepare() {
# Replace /var/run with /run, but not in the top source directory
sed -i -e 's|/var\(/run/fail2ban\)|\1|g' $( find . -mindepth 2 -type f ) || die

# Fix bashisms and do not direct useful output to /dev/null (bug #536320)
# Remove global logrotate settings (bug #549856)

distutils-r1_src_prepare
}

python_test() {
${EPYTHON} bin/${PN}-testcases
}

src_install() {
distutils-r1_src_install

rm -rf "${D}"/usr/share/doc/${PN} "${D}"/run

# not FILESDIR
newconfd files/gentoo-confd ${PN}
newinitd files/gentoo-initd ${PN}
systemd_dounit files/${PN}.service
systemd_dotmpfilesd files/${PN}-tmpfiles.conf
doman man/*.{1,5}

# Use INSTALL_MASK if you do not want to touch /etc/logrotate.d.
# See http://thread.gmane.org/gmane.linux.gentoo.devel/35675
insinto /etc/logrotate.d
newins files/${PN}-logrotate ${PN}
}

pkg_preinst() {
has_version "<${CATEGORY}/${PN}-0.7"
previous_less_than_0_7=$?
}

pkg_postinst() {
if [[ $previous_less_than_0_7 = 0 ]] ; then
elog
elog "Configuration files are now in /etc/fail2ban/"
elog "You probably have to manually update your configuration"
elog "files before restarting Fail2ban!"
elog
elog "Fail2ban is not installed under /usr/lib anymore. The"
elog "new location is under /usr/share."
elog
elog "You are upgrading from version 0.6.x, please see:"
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
if ! has_version ${CATEGORY}/${PN}; then
if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
elog "For most jail.conf configurations, it is recommended you install either"
elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
elog "to control how log file modifications are detected"
fi
if ! has_version dev-lang/python[sqlite]; then
elog "If you want to use ${PN}'s persistent database, then reinstall"
elog "dev-lang/python with USE=sqlite"
fi

if has_version sys-apps/systemd[-python]; then
elog "If you want to track logins through sys-apps/systemd's"
elog "journal backend, then reinstall sys-apps/systemd with USE=python"
fi
fi
}

0 comments on commit 1bbd415

Please sign in to comment.