Skip to content

Commit

Permalink
dev-python/yara-python: new ebuild
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/800275
Closes: https://bugs.gentoo.org/576956
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Mario Haustein <[email protected]>
Closes: gentoo#23800
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
hamarituc authored and thesamesam committed Jan 28, 2022
1 parent bbe0fd0 commit 1bc23b7
Show file tree
Hide file tree
Showing 6 changed files with 53 additions and 2 deletions.
1 change: 1 addition & 0 deletions app-forensics/yara/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,7 @@
<flag name='macho'>Enable macho module</flag>
<flag name='magic'>Enable magic module</flag>
<flag name='profiling'>Enable rules profiling</flag>
<flag name='python'>Pulls in python binding via <pkg>dev-python/yara-python</pkg></flag>
</use>
<upstream>
<remote-id type="github">VirusTotal/yara</remote-id>
Expand Down
3 changes: 2 additions & 1 deletion app-forensics/yara/yara-4.1.3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -12,14 +12,15 @@ SRC_URI="https://github.com/virustotal/yara/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+dex +dotnet +cuckoo +macho +magic profiling"
IUSE="+dex +dotnet +cuckoo +macho +magic profiling python"

DEPEND="
dev-libs/openssl:0=
cuckoo? ( dev-libs/jansson:= )
magic? ( sys-apps/file:0= )
"
RDEPEND="${DEPEND}"
PDEPEND="python? ( =dev-python/yara-python-4* )"

src_prepare() {
default
Expand Down
3 changes: 2 additions & 1 deletion app-forensics/yara/yara-4.2.0_rc1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -12,14 +12,15 @@ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.ta
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
IUSE="+dex +dotnet +cuckoo +macho +magic profiling"
IUSE="+dex +dotnet +cuckoo +macho +magic profiling python"

DEPEND="
dev-libs/openssl:0=
cuckoo? ( dev-libs/jansson:= )
magic? ( sys-apps/file:0= )
"
RDEPEND="${DEPEND}"
PDEPEND="python? ( =dev-python/yara-python-4* )"

S="${WORKDIR}/${PN}-${PV/_/-}"

Expand Down
1 change: 1 addition & 0 deletions dev-python/yara-python/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST yara-python-4.1.3.tar.gz 33712 BLAKE2B 7878d12620f2834578c98a99bc259422d8ac54efc04ebd29ffa604c15b0462607ce950b3e19f8e80db07195e61dedb4efc8c2ffb18a0c5de0bf2755fe62776d1 SHA512 9c96ae78df7694dd55b8bdde4fad49043f120b94477fa9d7090610665072626eba4fa410cd9292205e0b18bb9f384f07288c0340232e163294b91051b84dcab2
20 changes: 20 additions & 0 deletions dev-python/yara-python/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Mario Haustein</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Sam James</name>
</maintainer>
<longdescription>
With this library you can use YARA from your Python programs. It covers
all YARA's features, from compiling, saving and loading rules to
scanning files, strings and processes.
</longdescription>
<upstream>
<remote-id type="github">VirusTotal/yara-python</remote-id>
</upstream>
</pkgmetadata>
27 changes: 27 additions & 0 deletions dev-python/yara-python/yara-python-4.1.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )

inherit distutils-r1

DESCRIPTION="Python interface for a malware identification and classification tool"
HOMEPAGE="https://github.com/VirusTotal/yara-python"
SRC_URI="https://github.com/virustotal/yara-python/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="${PYTHON_DEPS}
=app-forensics/yara-4.1*"
DEPEND="${RDEPEND}"

src_compile() {
compile_python() {
distutils-r1_python_compile --dynamic-linking
}
python_foreach_impl compile_python
}

0 comments on commit 1bc23b7

Please sign in to comment.