Skip to content

Commit

Permalink
app-admin/consul: Bump to version 1.6.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Nov 19, 2019
1 parent 9c01911 commit 1c13834
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/consul/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST consul-1.5.3.tar.gz 21743194 BLAKE2B c797b04457c5f0b12f06732a94038b25367b53a9e6088d725eea61786a0e18bd905ad680bc12c4bfa30b44292d2676689dd6f18e9e2143bf6e1b02c2c55f678f SHA512 3f275ec160b9e583b81ba8d463fdb05e9fc9058db2453d9393a56b67337ea04df98a89225323192230938e1abfb48fa60fe0a32b4d8980573b749217b69933e9
DIST consul-1.6.1.tar.gz 22621651 BLAKE2B b696823d3f7f3ef135ba578f3c4ae76f78a1f172e083a3bb5cd07212b3907aefbac3fc0a1d68c5d494e7781cb84c686e2cfb1e5f7cd2d34f8bf671be84b3ca00 SHA512 c96855f3a344699580e34d6f45efe863ba4e6b23ef0889a22ee89bad8ffa807b3cec1a9d14604a340b16b0a8df8227c9eeacd507f94e4a19b25e0385ca5155ac
DIST consul-1.6.2.tar.gz 22041280 BLAKE2B 0b2edcd68fa166c178587a1ed3ca0445847d34510cd4e341f85a370257958a155ef6f976b045fc8e87af39107a3930ccb6d7a798ad142e87362f82d68ece4c3c SHA512 2df67854b85fa27600bf2cd57c913669f784019ee5a25b20a950ab00a403ca0562d74cb73c3402ebcec6cd951d7b9b4eb80c926746bcc27050db85f31192f826
74 changes: 74 additions & 0 deletions app-admin/consul/consul-1.6.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit golang-vcs-snapshot systemd user
GIT_COMMIT="1200f25"
KEYWORDS="~amd64"
EGO_PN="github.com/hashicorp/consul"
DESCRIPTION="A tool for service discovery, monitoring and configuration"
HOMEPAGE="https://www.consul.io"
SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"

SLOT="0"
LICENSE="MPL-2.0 Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT"
IUSE=""

RESTRICT="test"

DEPEND="dev-go/gox
>=dev-lang/go-1.11:=
>=dev-go/go-tools-0_pre20160121"
RDEPEND=""

pkg_setup() {
enewgroup consul
enewuser consul -1 -1 /var/lib/${PN} consul
}

src_prepare() {
default

# avoid network-sandbox violations since go-1.13
rm src/${EGO_PN}/go.mod || die
grep -rlZ '_ "github.com/envoyproxy/protoc-gen-validate/validate"' . | \
xargs -0 sed -i '/_ "github.com\/envoyproxy\/protoc-gen-validate\/validate"/d' || die

sed -e 's:go get -u -v $(GOTOOLS)::' \
-e 's:vendorfmt dev-build:dev-build:' \
-i "src/${EGO_PN}/GNUmakefile" || die
}

src_compile() {
# The dev target sets causes build.sh to set appropriate XC_OS
# and XC_ARCH, and skips generation of an unused zip file,
# avoiding a dependency on app-arch/zip.
GOPATH="${S}" \
GOBIN="${S}/bin" \
GIT_DESCRIBE="v${PV}" \
GIT_DIRTY="" \
GIT_COMMIT="${GIT_COMMIT}" \
emake -C "src/${EGO_PN}" dev-build
}

src_install() {
local x

dobin bin/consul

keepdir /etc/consul.d
insinto /etc/consul.d
doins "${FILESDIR}/"*.json.example

for x in /var/{lib,log}/${PN}; do
keepdir "${x}"
fowners consul:consul "${x}"
done

newinitd "${FILESDIR}/consul.initd" "${PN}"
newconfd "${FILESDIR}/consul.confd" "${PN}"
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotated" "${PN}"
systemd_dounit "${FILESDIR}/consul.service"
}

0 comments on commit 1c13834

Please sign in to comment.