forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-portage/eix: Version bump (v0.33.8)
Signed-off-by: Mikle Kolyada <[email protected]> Package-Manager: Portage-2.3.66, Repoman-2.3.11
- Loading branch information
Showing
2 changed files
with
105 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST eix-0.33.7.tar.xz 626008 BLAKE2B 13d1f5b3096ec1ced13435f3680454c5b6f035ddbaa7877c7d2898b044fcc673f2c30b5ad25b8a3aa01354c726cf6ebf6483dc49f102145957dad95437931f63 SHA512 a6f2f553a05351c642c5ad5dcb8dc804585e1476d35dbe2c056ed493d1e37576e5e57fe0317f4fe4f6310c5439d23cbbe7384da8fbe9761eddca10e463950077 | ||
DIST eix-0.33.8.tar.xz 627116 BLAKE2B b301b4218d60c13a8d6c4be484b65e9bc257e6c4d1989054cc844861cd6ec96194e60094e72833f82cfaf1b1d14a249045590dbfc91a39e5c92d5dae13b2c643 SHA512 014ce5b660430e117e8037d8043bdfe5e6e98b7cb889e88d93aeb87e650296a8db64871f3eb736842dbebde7eb1f23936f6df9f5f547f89565734b7874e6e907 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,104 @@ | ||
# Copyright 1999-2019 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools bash-completion-r1 flag-o-matic tmpfiles | ||
|
||
DESCRIPTION="Search and query ebuilds" | ||
HOMEPAGE="https://github.com/vaeth/eix/" | ||
SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | ||
IUSE="debug doc nls sqlite" | ||
|
||
BOTHDEPEND="nls? ( virtual/libintl ) | ||
sqlite? ( >=dev-db/sqlite-3:= )" | ||
RDEPEND="${BOTHDEPEND} | ||
>=app-shells/push-2.0-r1 | ||
>=app-shells/quoter-3.0_p2-r1" | ||
DEPEND="${BOTHDEPEND} | ||
app-arch/xz-utils | ||
nls? ( sys-devel/gettext )" | ||
|
||
pkg_setup() { | ||
# remove stale cache file to prevent collisions | ||
local old_cache=${EROOT%/}/var/cache/${PN} | ||
if [[ -f ${old_cache} ]]; then | ||
rm "${old_cache}" || die | ||
fi | ||
} | ||
|
||
src_prepare() { | ||
default | ||
sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die | ||
|
||
sed -e "/eixf_source=/s:push.sh:cat \"${EROOT}usr/share/push/push.sh\":" \ | ||
-e "/eixf_source=/s:quoter_pipe.sh:cat \"${EROOT}usr/share/quoter/quoter_pipe.sh\":" \ | ||
-i src/eix-functions.sh.in || die | ||
sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EROOT}usr/share/eix/eix-functions\\\\\":" \ | ||
-i src/Makefile.am || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
local myconf=( | ||
$(use_enable debug paranoic-asserts) | ||
$(use_enable nls) | ||
$(use_with doc extra-doc) | ||
$(use_with sqlite) | ||
|
||
# default configuration | ||
$(use_with prefix always-accept-keywords) | ||
--with-dep-default | ||
--with-required-use-default | ||
|
||
# paths | ||
--with-portage-rootpath="${ROOTPATH}" | ||
--with-eprefix-default="${EPREFIX}" | ||
|
||
# build a single executable with symlinks | ||
--disable-separate-binaries | ||
--disable-separate-tools | ||
|
||
# used purely to control/disrespect *FLAGS | ||
--disable-debugging | ||
--disable-new_dialect | ||
--disable-optimization | ||
--disable-strong-optimization | ||
--disable-security | ||
--disable-nopie-security | ||
--disable-strong-security | ||
) | ||
|
||
# https://github.com/vaeth/eix/issues/35 | ||
append-cxxflags -std=c++14 | ||
|
||
econf "${myconf[@]}" | ||
} | ||
|
||
src_install() { | ||
default | ||
dobashcomp bash/eix | ||
dotmpfiles tmpfiles.d/eix.conf | ||
|
||
rm -r "${ED%/}"/usr/bin/eix-functions.sh || die | ||
|
||
} | ||
|
||
pkg_postinst() { | ||
tmpfiles_process eix.conf | ||
|
||
local obs=${EROOT%/}/var/cache/eix.previous | ||
if [[ -f ${obs} ]]; then | ||
ewarn "Found obsolete ${obs}, please remove it" | ||
fi | ||
} | ||
|
||
pkg_postrm() { | ||
if [[ ! -n ${REPLACED_BY_VERSION} ]]; then | ||
rm -rf "${EROOT%/}/var/cache/${PN}" || die | ||
fi | ||
} |