Skip to content

Commit

Permalink
app-admin/clustershell: bump
Browse files Browse the repository at this point in the history
* PYTHON_COMPAT bump (3.9)
* EAPI 8 bump

Signed-off-by: Patrice Clement <[email protected]>
  • Loading branch information
monsieurp committed Nov 19, 2021
1 parent 9708625 commit 1c7ede6
Showing 1 changed file with 44 additions and 0 deletions.
44 changes: 44 additions & 0 deletions app-admin/clustershell/clustershell-1.8.3-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8,9} )
PYTHON_REQ_USE="xml"

inherit distutils-r1

DESCRIPTION="Python framework for efficient cluster administration"
HOMEPAGE="https://cea-hpc.github.com/clustershell/"
SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

BDEPEND="
test? ( dev-python/nose[${PYTHON_USEDEP}] )"

RDEPEND="
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-libs/openssl:0="

RESTRICT="test" # currently fail

python_install() {
distutils-r1_python_install
python_optimize
}

python_test() {
cd tests || die
nosetests -sv --all-modules || die
}

pkg_postinst() {
einfo
einfo "Some default system-wide config files have been installed into"
einfo "/etc/${PN}"
einfo
}

0 comments on commit 1c7ede6

Please sign in to comment.