Skip to content

Commit

Permalink
games-emulation/generator: Fix build system
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/656344
Closes: https://bugs.gentoo.org/686198
Closes: https://bugs.gentoo.org/707776
Closes: https://bugs.gentoo.org/724416
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jul 5, 2020
1 parent ba89ac4 commit 1c9532d
Show file tree
Hide file tree
Showing 6 changed files with 74 additions and 44 deletions.
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- a/configure.ac.original 2008-03-17 13:07:48.000000000 -0400
+++ b/configure.ac 2008-03-17 13:08:03.000000000 -0400
--- a/configure.ac
+++ b/configure.ac
@@ -28,15 +28,12 @@
AC_ARG_WITH(tcltk,
AS_HELP_STRING(--with-tcltk,Create tcltk version),
Expand Down Expand Up @@ -68,7 +68,15 @@
AC_CHECK_LIB(jpeg, jpeg_start_compress,
[ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])

@@ -272,14 +225,7 @@
@@ -259,6 +212,7 @@
AC_PROG_CC
AC_PROG_CPP
AC_PROG_RANLIB
+ AM_PROG_AR
AC_PROG_MAKE_SET
AC_ISC_POSIX
AC_PROG_INSTALL
@@ -272,14 +226,7 @@

AC_PATH_XTRA

Expand All @@ -84,7 +92,7 @@
MY_SUBDIRS="gtkopts $MY_SUBDIRS"
AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))

@@ -305,6 +251,7 @@
@@ -305,6 +252,7 @@
AC_CHECK_SIZEOF(unsigned long, 4)
AC_CHECK_SIZEOF(unsigned long long, 8)
AC_CHECK_HEADERS(sys/param.h)
Expand Down
26 changes: 26 additions & 0 deletions games-emulation/generator/files/generator-0.35_p4-automake.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
--- a/cpu68k/Makefile.am
+++ b/cpu68k/Makefile.am
@@ -29,6 +29,7 @@

gen68k_SOURCES = gen68k.c tab68k.c
gen68k_DEPENDENCIES = def68k-iibs.h
+BUILT_SOURCES = def68k-iibs.h

noinst_LIBRARIES = lib68k.a
lib68k_a_SOURCES = cpu68k-0.c cpu68k-1.c cpu68k-2.c cpu68k-3.c \
--- a/main/Makefile.am
+++ b/main/Makefile.am
@@ -3,11 +3,11 @@
INCLUDES = -I../hdr -I. -I../cpu68k -I../ym2612 -I../raze -I../cmz80 \
-I../sn76496 -I../gtkopts \
-DFNAME_TCLSCRIPT=\"${datadir}/generator/gen.tcl\" \
- @GTK_CFLAGS@ @SDL_CFLAGS@
+ @SDL_CFLAGS@
bin_PROGRAMS = @PROGRAM@
EXTRA_PROGRAMS = generator-svgalib generator-tcltk generator-allegro \
generator-gtk generator-sdl
-LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ \
+LDADD = ../cpu68k/lib68k.a ../ym2612/libym2612.a @MY_LIBS@ -lm \
../sn76496/libsn76496.a

## this should be generator_tcltk_DATA but it won't let me do that
Original file line number Diff line number Diff line change
@@ -1,8 +1,17 @@
https://bugs.gentoo.org/698944

--- a/hdr/cpuz80.h
+++ b/hdr/cpuz80.h
@@ -5,7 +5,7 @@
# include "raze.h"
#else
# include "cmz80.h"
-CONTEXTMZ80 cpuz80_z80; /* extern'd for save state code */
+extern CONTEXTMZ80 cpuz80_z80; /* extern'd for save state code */
#endif

#define LEN_SRAM 0x2000
--- a/main/vdp.c
+++ b/main/vdp.c
@@ -87,7 +87,7 @@ void vdp_describe(void);
@@ -87,7 +87,7 @@
void vdp_eventinit(void);
void vdp_layer_simple(unsigned int layer, unsigned int priority,
uint8 *fielddata, unsigned int lineoffset);
Expand All @@ -11,7 +20,7 @@ https://bugs.gentoo.org/698944
uint8 *cellloc, unsigned int lineoffset);
void vdp_sprites(unsigned int line, uint8 *pridata, uint8 *outdata);
int vdp_sprite_simple(unsigned int priority, uint8 *framedata,
@@ -1733,7 +1733,7 @@ void vdp_endfield(void)
@@ -1733,7 +1733,7 @@
vdp_event_endline); */
}

Expand All @@ -20,3 +29,14 @@ https://bugs.gentoo.org/698944
uint8 *cellloc, unsigned int lineoffset)
{
int y, x;
--- a/ym2612/support.h
+++ b/ym2612/support.h
@@ -3,7 +3,7 @@
#include "config.h"

#define errorlog 0
-#define INLINE inline
+#define INLINE
#define HAS_YM2612 1
#define YM2612UpdateRequest(x)
#define AY8910_set_clock(chip,clock)
12 changes: 0 additions & 12 deletions games-emulation/generator/files/generator-0.35_p4-inline.patch

This file was deleted.

11 changes: 0 additions & 11 deletions games-emulation/generator/files/generator-0.35_p4-underlink.patch

This file was deleted.

25 changes: 12 additions & 13 deletions games-emulation/generator/generator-0.35_p4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -1,7 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
EAPI=7

inherit autotools toolchain-funcs

MY_P="${PN}-${PV/_p/-cbiere-r}"
Expand All @@ -14,26 +15,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+sdlaudio"

DEPEND="
RDEPEND="
virtual/jpeg:0
media-libs/libsdl[joystick,video]
sdlaudio? ( media-libs/libsdl[sound] )
"
RDEPEND="${DEPEND}"
sdlaudio? ( media-libs/libsdl[sound] )"
DEPEND="${RDEPEND}"

S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}"/${P}-configure.patch
"${FILESDIR}"/${P}-underlink.patch
"${FILESDIR}"/${P}-inline.patch
"${FILESDIR}"/${P}-gcc-9.patch
"${FILESDIR}"/${P}-autoconf.patch
"${FILESDIR}"/${P}-automake.patch
"${FILESDIR}"/${P}-gcc.patch
)

src_prepare() {
default

sed -i -e 's/@GTK_CFLAGS@//g' main/Makefile.am || die
eautoreconf
}

Expand All @@ -48,5 +45,7 @@ src_configure() {

src_install() {
dobin main/generator-sdl
dodoc AUTHORS ChangeLog NEWS README TODO docs/*

einstalldocs
dodoc -r docs/.
}

0 comments on commit 1c9532d

Please sign in to comment.