Skip to content

Commit

Permalink
games-arcade/thinktanks-demo: Stop using games.eclass
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.31, Repoman-2.3.9
  • Loading branch information
pacho2 committed Apr 24, 2018
1 parent b211971 commit 1ca4a37
Showing 1 changed file with 49 additions and 0 deletions.
49 changes: 49 additions & 0 deletions games-arcade/thinktanks-demo/thinktanks-demo-1.1-r3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit desktop unpacker

DESCRIPTION="Tank combat game with lighthearted, fast paced pandemonium"
HOMEPAGE="http://www.garagegames.com/pg/product/view.php?id=12"
SRC_URI="ftp://ggdev-1.homelan.com/thinktanks/ThinkTanksDemo_v${PV}.sh.bin"

LICENSE="THINKTANKS"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
RESTRICT="strip"

RDEPEND="
media-libs/libsdl[video,joystick,abi_x86_32(-)]
media-libs/libogg[abi_x86_32(-)]
media-libs/libvorbis[abi_x86_32(-)]
x11-libs/libX11[abi_x86_32(-)]
x11-libs/libXext[abi_x86_32(-)]
"
DEPEND=""

S="${WORKDIR}"
dir="/opt/${PN}"

QA_PREBUILT="${dir:1}/ThinkTanks.bin"

src_install() {
dodir "${dir}" "/usr/bin"

tar -zxf ThinkTanks.tar.gz -C "${ED}/${dir}" || die

exeinto "${dir}"
doexe bin/Linux/x86/thinktanksdemo
dosym "${dir}"/thinktanksdemo /usr/bin/thinktanks-demo
# Using system libraries
rm -rf "${ED}/${dir}"/lib

insinto "${dir}"
doins icon.xpm

newicon icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Thinktanks (Demo)" /usr/share/pixmaps/${PN}.xpm

dodoc ReadMe_Linux.txt
}

0 comments on commit 1ca4a37

Please sign in to comment.